php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51123 Mail function error can't to connect mail server.
Submitted: 2010-02-23 12:46 UTC Modified: 2010-02-24 12:40 UTC
From: som_sea at hotmail dot com Assigned:
Status: Not a bug Package: Mail related
PHP Version: 5.2.12 OS: Windows XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: som_sea at hotmail dot com
New email:
PHP Version: OS:

 

 [2010-02-23 12:46 UTC] som_sea at hotmail dot com
Description:
------------
Background version. AppServ Open Project - 2.5.8 for Windows :
Apache Web Server Version 2.2.4
PHP Script Language Version 5.2.1
MySQL Database Version 5.0.27
phpMyAdmin Database Manager Version 2.9.2

Problem:Can not connect to mail sever.
Error msg.
Warning: mail() [function.mail]: Failed to connect to mailserver at "XXXXXX" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\AppServ\www\xxx.php on line xx
=====
If use this script/mailserver/ini-mail-set with php ver.4.xx(Appserv v.2.4) its work.

How can do???



Actual result:
--------------
Warning: mail() [function.mail]: Failed to connect to mailserver at "XXXXXX" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\AppServ\www\xxx.php on line xx

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-23 13:02 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2010-02-24 12:40 UTC] som_sea at hotmail dot com
Thanks jani.
i try to search in php support but not found any answer can help me. 
as i test, if php v.5.0 and down mail function are work.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 23:05:45 2022 UTC