php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51113 setcookie doesn't send cookie when path and domain set
Submitted: 2010-02-22 14:22 UTC Modified: 2010-02-22 14:40 UTC
From: info at milde dot cz Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 5.3.1 OS: Arch Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: info at milde dot cz
New email:
PHP Version: OS:

 

 [2010-02-22 14:22 UTC] info at milde dot cz
Description:
------------
If setcookie is called with domain and path arguments, it does nothing.



Reproduce code:
---------------
print_r($_COOKIE);

echo setcookie('test', 'test', time()+3600, '/', 'localhost');

Expected result:
----------------
Array ( [test] => test ) 1

Actual result:
--------------
Array ( ) 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-22 14:23 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2010-02-22 14:40 UTC] info at milde dot cz
Ah, sorry, looks like Firefox bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Oct 05 15:05:52 2022 UTC