php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51005 --without-sqlite3 should be --with-sqlite3
Submitted: 2010-02-10 22:09 UTC Modified: 2010-02-12 17:04 UTC
From: geissert at debian dot org Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.3.1 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: geissert at debian dot org
New email:
PHP Version: OS:

 

 [2010-02-10 22:09 UTC] geissert at debian dot org
Description:
------------
I just noticed sqlite3's config0.m4 has an inverted logic:

--without-sqlite3 defaults to yes, which instead of NOT including sqlite3 it _does_ include it (using the bundled copy).

--without-sqlite3=/foo also makes it include the extension, looking for the headers under /foo

--without-sqlite3=no does not include it.

IOW: the option should be called --with-sqlite3, not --without-sqlite3



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-10 22:32 UTC] rasmus@php.net
The option is called --with-sqlite3.  That's how autoconf works.  You 
have --enable/--disable and --with/--without switches.  If the feature 
is on by default then you use --disable/--without to turn it off.  If 
the feature is off by default, then it is the opposite.  Try it by 
using --with-sqlite3=/some/path

But yes, the yes/no responses are messed up when using these.  
 [2010-02-10 23:00 UTC] geissert at debian dot org
Sorry for not being specific, I was talking about the description on the m4 file:

PHP_ARG_WITH(sqlite3, whether to enable the SQLite3 extension,
[  --without-sqlite3[=DIR] Do not include SQLite3 support. DIR is the prefix to
                          SQLite3 installation directory.], yes)
 [2010-02-11 00:37 UTC] rasmus@php.net
Yes, I am aware of that, but it is --without-sqlite3 there because by 
default if you don't specify anything you get sqlite3 compiled in since 
we bundle that library.  So when you do ./configure --help you should 
see --without-sqlite3 as the listed option letting you know to use that 
to build PHP without it.
 [2010-02-12 17:04 UTC] jani@php.net
There's neither any bug here or anything wrong with the description logic. Nor does it affect any working parts. :)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 15:01:28 2020 UTC