php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50998 unaligned memory access in hash_tiger.c
Submitted: 2010-02-10 19:06 UTC Modified: 2010-05-20 12:21 UTC
From: geissert at debian dot org Assigned:
Status: Not a bug Package: hash related
PHP Version: 5.3SVN-2010-02-12 OS: linux ia64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: geissert at debian dot org
New email:
PHP Version: OS:

 

 [2010-02-10 19:06 UTC] geissert at debian dot org
Description:
------------
ext/hash/hash_tiger.c's TigerFinalize makes an unaligned memory access at:

        tiger_compress(context->passes, ((php_hash_uint64 *) context->buffer), context->state);



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-10 21:06 UTC] geissert at debian dot org
Failed test: ext/hash/tests/mhash_001.phpt

Output:
MHASH_MD5
ok

MHASH_SHA1
ok

MHASH_HAVAL256
ok

MHASH_HAVAL192
ok

MHASH_HAVAL224
ok

MHASH_HAVAL160
ok

MHASH_RIPEMD160
ok

MHASH_GOST
ok

Bus error (core dumped)
 [2010-02-19 15:15 UTC] srinatar@php.net
looks like this is Intel Itanium specific and not reproduced in other 
platforms
 [2010-05-20 12:21 UTC] mike@php.net
-Status: Open +Status: Bogus
 [2010-05-20 12:21 UTC] mike@php.net
Dupe of Bug #51003
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Nov 27 00:03:13 2021 UTC