php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50986 using swf object the flv extension videos not playing
Submitted: 2010-02-10 07:21 UTC Modified: 2010-02-10 10:16 UTC
From: bhupinder1045 at gmail dot com Assigned:
Status: Not a bug Package: *PDF functions
PHP Version: 5.3.1 OS: Vista
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: bhupinder1045 at gmail dot com
New email:
PHP Version: OS:

 

 [2010-02-10 07:21 UTC] bhupinder1045 at gmail dot com
Description:
------------
 <script type="text/javascript" src="../flashplayer/swfobject.js"></script>
		  <div id="flashplayer"></div> 
		  <div id="container" style="padding-left:4px"></div>
		  <script type="text/javascript">
		  
		  
			var file  = "<?php echo $videoName!='' ? $videoName : ''; ?>"; // for uploaded file name.
			//var utube = "<?php echo $youLink!='' ? $youLink : ''; ?>"; // for utube link..		
            alert(file)

		   var s1 = new swf("../flashplayer/mediaplayer.swf","mediaplayer","500","320","8");
		

		//var s1 = new SWFObject("../flashplayer/mediaplayer.swf","mediaplayer","500","320","8");
			


			s1.addParam("allowfullscreen","true");
			s1.addVariable("width","500");
			s1.addVariable("height","320");

			s1.addVariable("autostart","false"); // 'true' terurn auto run
			s1.addVariable("repeat","true"); // 'true' terurn auto run

           s1.addVariable("autoPlay", "no");
		  // s1.addVariable("soundPath", "<?php echo VIDEO_PATH.$getVideo['video_filename']; ?>");
		   //s1.write("flashplayer");


		alert(file)
		//	if(utube == '')
			s1.addVariable("file",file);			
		//	else
		//	s1.addVariable("file",utube);
			s1.write("container");
		</script>

Reproduce code:
---------------
---
From manual page: function.swf-actionplay#Description
---



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-10 10:16 UTC] pajoye@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 18 11:03:30 2022 UTC