php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50912 can't install PDO-PGSQL
Submitted: 2010-02-02 13:38 UTC Modified: 2010-02-03 19:51 UTC
Votes:7
Avg. Score:5.0 ± 0.0
Reproduced:7 of 7 (100.0%)
Same Version:7 (100.0%)
Same OS:6 (85.7%)
From: michaelstrasser at tele2 dot at Assigned:
Status: Not a bug Package: PDO related
PHP Version: 5.3SVN-2010-02-02 (snap) OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michaelstrasser at tele2 dot at
New email:
PHP Version: OS:

 

 [2010-02-02 13:38 UTC] michaelstrasser at tele2 dot at
Description:
------------
Hi,

I am using Windows XP with PHP 5.3 and I can't install PDO_PGSQL. This is what Pecl tells me:

C:\Dokumente und Einstellungen\Michael>pecl install pdo_pgsql
downloading PDO_PGSQL-1.0.2.tgz ...
Starting to download PDO_PGSQL-1.0.2.tgz (14,961 bytes)
.....done: 14,961 bytes
downloading PDO-1.0.3.tgz ...
Starting to download PDO-1.0.3.tgz (52,613 bytes)
...done: 52,613 bytes
12 source files, building
ERROR: The DSP PDO.dsp does not exist.
7 source files, building
ERROR: The DSP PDO_PGSQL.dsp does not exist.

Unfortunately the PECL site, where I could get snapshots of the extensions, is down. So I have no clue where to get the extension from.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-03 19:33 UTC] jb at gmx dot at
I think the source of the problem is that PHP 5.3 is not compatible with windows xp. Try using linux instead.
 [2010-02-03 19:51 UTC] pajoye@php.net
PDO PGSQL is part of the core distribution since years. Latest PHP releases include the PGSQL library and extensions, use them instead of PECL, on windows or source releases.
 [2010-11-10 01:41 UTC] josh at endries dot org
This buug entry is NOT bogus. I just installed PHP from the web site and get this same error. PDO PGSQL is *NOT* included. I will submit a new ticket to actually get this addressed properly.
 [2010-11-10 02:08 UTC] josh at endries dot org
The correct (I think) answer to this problem is that the pecl binary doesn't work on Windows. Instead, go into Add/Remove Programs (or its equivalent) and select "Change" for PHP. In the install program, (de)select the options you want.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Mar 03 09:01:23 2021 UTC