php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50818 SQLSTATE[HY093]: Invalid parameter number: parameter was not defined
Submitted: 2010-01-22 00:36 UTC Modified: 2010-04-23 16:12 UTC
From: saschagros at gmail dot com Assigned:
Status: Not a bug Package: PDO related
PHP Version: 6SVN-2010-01-22 (snap) OS: Linux (Ubuntu)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: saschagros at gmail dot com
New email:
PHP Version: OS:

 

 [2010-01-22 00:36 UTC] saschagros at gmail dot com
Description:
------------
Once again trying to get Drupal to run with PHP 6.

I'm getting the following error on the first query that is run..

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY093]: Invalid parameter number: parameter was not defined' in .../drupal7/includes/database/database.inc:1941

That line looks like this:
<?php
    $return = parent::execute($args);
?>
Note: parent is PDOStatement.

The executed query:
unicode(87) "SELECT data, created, headers, expire, serialized FROM cache_bootstrap WHERE cid = :cid"

$args contains:
array(1) {
  [u":cid"]=>
  unicode(9) "variables"
}

I would suspect that it does have something to do with unicode.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-24 13:26 UTC] uw@php.net
There's no PHP 6 any more. What shall happen to those reports: close, bogus, test against 5.3, test against new trunk?
 [2010-04-23 16:12 UTC] felipe@php.net
-Status: Open +Status: Bogus
 [2010-04-23 16:12 UTC] felipe@php.net
.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Mar 02 15:01:24 2021 UTC