php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50672 FR: <?dbtimestamp?> support
Submitted: 2010-01-05 20:43 UTC Modified: 2010-01-06 17:37 UTC
From: hannes dot magnusson at gmail dot com Assigned: moacir (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hannes dot magnusson at gmail dot com
New email:
PHP Version: OS:

 

 [2010-01-05 20:43 UTC] hannes dot magnusson at gmail dot com
Description:
------------
There exists a neat PI to generate date/time stamps[1].
Zend Framework already use it for their documentations, and it could 
replace the newly-introduced entity trick[2].

Worth looking into.

NOTE: Docbook-XSL supports several format characters, but these do not 
match the date() format characters (see for example the 'S' character)!
We should probably only implements the chars defined in the "spec", 
using some sort of "lookup array" from the dbtimestamp format character 
to date() format character.

[1] http://www.sagehill.net/docbookxsl/Datetime.html
[2] http://svn.php.net/viewvc?view=revision&revision=293139

Reproduce code:
---------------
<para>This document was generated <?dbtimestamp format="Y"?>.</para>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-06 17:37 UTC] bjori@php.net
This bug has been fixed in SVN. Since the websites are not directly
updated from the SVN server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

Fixed in r293178
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 17:05:53 2022 UTC