php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50671 Missing root page
Submitted: 2010-01-05 20:35 UTC Modified: 2010-01-05 20:35 UTC
From: hannes dot magnusson at gmail dot com Assigned:
Status: Closed Package: Doc Build problem
PHP Version: 5.3SVN-2010-01-05 (SVN) OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: hannes dot magnusson at gmail dot com
New email:
PHP Version: OS:

 

 [2010-01-05 20:35 UTC] hannes dot magnusson at gmail dot com
Description:
------------
For some reason the root <book> chunk loses its name when there is an 
empty <index /> element in the body

Reproduce code:
---------------
Taken from the Zend Framework manual:

<book xmlns="http://docbook.org/ns/docbook" version="5.0" xml:id="manual" xml:lang="en">
    <info><title>Programmer's Reference Guide</title><subtitle>Zend Framework</subtitle>
               
               
        <copyright>
            <holder>
                Zend Technologies Inc.
                (<uri xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="http://www.zend.com">http://www.zend.com</uri>)
            </holder>
        </copyright>
    </info>

    <index xml:id="the.index" />
</book>


Expected result:
----------------
a manual.html page and an empty index <div>

Actual result:
--------------
a file called ".html"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-05 20:35 UTC] svn@php.net
Automatic comment from SVN on behalf of bjori
Revision: http://svn.php.net/viewvc/?view=revision&revision=293153
Log: Fixed bug#50671 (Missing root page)
 [2010-01-05 20:35 UTC] bjori@php.net
This bug has been fixed in SVN. Since the websites are not directly
updated from the SVN server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 21:01:27 2024 UTC