php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50584 Windows installer does not configure Apache in silent mode
Submitted: 2009-12-26 23:52 UTC Modified: 2010-05-12 21:18 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: mkucej at yahoo dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.3.1 OS: Windows XP SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
33 + 40 = ?
Subscribe to this entry?

 
 [2009-12-26 23:52 UTC] mkucej at yahoo dot com
Description:
------------
Windows installer does not configure Apache in silent mode. It will insert the following into the httpd.conf:

#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL

This happens only in the silent mode.

Reproduce code:
---------------
msiexec /I php.msi /qn+ INSTALLDIR="C:\Program Files\PHP" APACHEDIR="C:\Program Files\Apache Software Foundation\Apache2.2\conf\" ADDLOCAL=ScriptExecutable,cgi,apache22,ext_php_pdo_sqlite /L c:\log.txt

Actual result:
--------------
#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-25 21:14 UTC] jmertic@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: jmertic
 [2010-04-04 05:45 UTC] mkucej at yahoo dot com
This problem persists in the 5.3.2 installer. Anybody cares?
 [2010-05-12 21:18 UTC] jmertic@php.net
Automatic comment from SVN on behalf of jmertic
Revision: http://svn.php.net/viewvc/?view=revision&revision=299304
Log: Bug #50584 - Fix problem with expecting newly created registry values to be available in the VB installer scripts by instead passing those values to the custom action via CustomActionData property.
 [2010-05-12 21:18 UTC] jmertic@php.net
-Status: Assigned +Status: Closed
 [2010-05-12 21:18 UTC] jmertic@php.net
Fixed issues in SVN of this happening both when configuring Apache or IIS via the command line installer.
 [2011-10-11 21:57 UTC] Jean dot GlandePasUne at gmail dot com
Same issue with the "noisy" installer: Apache isn't seen despite it's installed and running well ! And no, nobody cares because free = you're alone.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 16:03:34 2022 UTC