php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50448 Unable to load dynamic library 'c:/php/ext\\php_java.dll'
Submitted: 2009-12-11 07:49 UTC Modified: 2009-12-11 09:47 UTC
From: vsanam at 1fbusa dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.3.1 OS: Windows XP Professional 2002
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vsanam at 1fbusa dot com
New email:
PHP Version: OS:

 

 [2009-12-11 07:49 UTC] vsanam at 1fbusa dot com
Description:
------------
I am using the following softwares installed in my application.
1. php-5.3.1-Win32-VC6-x86.ZIP
2. apache_2.2.14-win32-x86-no_ssl.msi
3. jdk1.5.0_13.

I have downloaded the file "JavaBridgeTemplate5541.war" from "http://sourceforge.net/projects/php-java-bridge/files/Binary%20package/" site and place the JavaBridge.jar from "JavaBridgeTemplate5541.war" into "c:/php/ext". The file "php_java.dll" not found in the "JavaBridgeTemplate5541.war" to place in the "c:/php/ext".

When I tried to restart and run the Apache http Server I unable to see the "Java" option in the "php configuration options" with the following syntax: <?php phpinfo(); ?> when run on the browser with the URL "http://localhost/".





Reproduce code:
---------------
Configured the file "php.ini" with the following lines:

 extension_dir = "c:/php/ext"

[java]
java.java_home = "C:/Program Files/Java/jdk1.5.0_13"
java.java = "C:/Program Files/Java/jdk1.5.0_13/bin/javaw.exe"
java.class.path = "C:/php/ext/JavaBridge.jar"
java.library.path = "C:/php/ext"
java.log_level=2

Expected result:
----------------
I should see the "Java" option when I run the 
"index.php" file.

"index.php":

<?php 
phpinfo();
?>

Java

Java Enabled: true;
Java Bridge: 5.5.4
Java status : running


Actual result:
--------------
This is the following error I can see in the "error log" file of the appache http server.

PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/php/ext\\php_java.dll' - The specified module could not be found.\r\n in Unknown on line 0



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-12-11 09:47 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Mar 01 18:01:28 2024 UTC