php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50397 PHP CLI core dumped when curl extension enabled
Submitted: 2009-12-07 11:36 UTC Modified: 2009-12-07 12:16 UTC
From: ABOCb at yandex dot ru Assigned:
Status: Not a bug Package: cURL related
PHP Version: 5.2.11 OS: FreeBSD 7.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ABOCb at yandex dot ru
New email:
PHP Version: OS:

 

 [2009-12-07 11:36 UTC] ABOCb at yandex dot ru
Description:
------------
PHP 5.2.1, compiled from ports. Extensions allowed: session, ctype, iconv, mbstring, gd, zlib, pcre, mysql, simplexml, xml, spl.

Work correctly as Apache module as CLI. After allowing curl extension, got a segmentation fault:

$ php -v
PHP 5.2.11 with Suhosin-Patch 0.9.7 (cli) (built: Dec  7 2009 17:13:42)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
Segmentation fault: 11 (core dumped)

GDB backtrace:
$ gdb /usr/local/bin/php php.core
GNU gdb 6.1.1 [FreeBSD]
...
Core was generated by `php'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libcrypt.so.4...(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypt.so.4
Reading symbols from /lib/libm.so.5...(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.5
Reading symbols from /usr/local/lib/libxml2.so.5...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libxml2.so.5
Reading symbols from /lib/libz.so.4...(no debugging symbols found)...done.
Loaded symbols for /lib/libz.so.4
Reading symbols from /usr/local/lib/libiconv.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libiconv.so.3
Reading symbols from /lib/libc.so.7...(no debugging symbols found)...done.
Loaded symbols for /lib/libc.so.7
Reading symbols from /libexec/ld-elf.so.1...(no debugging symbols found)...done.
Loaded symbols for /libexec/ld-elf.so.1
#0  0x28cc5410 in ?? ()
(gdb) where
#0  0x28cc5410 in ?? ()
#1  0x285a15eb in pthread_once () from /lib/libc.so.7
#2  0x28347162 in xmlIsMainThread () from /usr/local/lib/libxml2.so.5
#3  0x28346717 in __xmlLastError () from /usr/local/lib/libxml2.so.5
#4  0x282d2847 in xmlResetLastError () from /usr/local/lib/libxml2.so.5
#5  0x282d98df in xmlCleanupParser () from /usr/local/lib/libxml2.so.5
#6  0x0808475b in php_libxml_shutdown ()
#7  0x0808478b in zm_shutdown_libxml ()
#8  0x0814bc3e in module_destructor ()
#9  0x08151fa4 in zend_hash_apply_deleter ()
#10 0x081521e8 in zend_hash_graceful_reverse_destroy ()
#11 0x081484be in zend_shutdown ()
#12 0x081061df in php_module_shutdown ()
#13 0x081c54a0 in main ()


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-12-07 12:16 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

a) We don't support FreeBSD ports as they apply third-party patches
b) We don't support suhosin

Anyways: Please try to change the load order in your php.ini file in regards to zlib, suhosin and xml stuff.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 21 17:01:22 2019 UTC