php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50290 5.3.1 iis fast cgi module time out on accessing mysql
Submitted: 2009-11-24 23:22 UTC Modified: 2009-12-15 12:38 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:4 (100.0%)
From: praveen at aexea dot net Assigned: mysql (profile)
Status: Not a bug Package: MySQL related
PHP Version: 5.3.1 OS: vista business
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: praveen at aexea dot net
New email:
PHP Version: OS:

 

 [2009-11-24 23:22 UTC] praveen at aexea dot net
Description:
------------
When upgraded php from 5.3.0 to latest 5.3.1 on IIS7 - Fast-CGI (vista 
business) edition. IIS7-fast cgi times out when any page is accessed 
which have mysql functions.

All other things are working fine, problem is only with pages which use 
mysql.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-25 06:44 UTC] pajoye@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2009-11-27 12:33 UTC] avivahl at gmail dot com
Probably related to: http://bugs.php.net/bug.php?id=50172
 [2009-12-03 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2009-12-11 12:32 UTC] bramus at bram dot us
Same issue here (PHP 5.3.1 as a  fastcgi module in IIS7). Getting timeouts and HTTP 500 codes whenever I encounter a script that wants to connect to a MySQL server.

Internal logging of my app tells me that the mysql(i)_connect function fails: "Could not connect. A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."

After reverting to an older version of PHP (pre 5.3.1) all works fine again.

@pajoye: sample code is really simple:
<?php

// this will fail in PHP 5.3.1 on IIS7 (fastcgi) even though the DB server is up and the credentials are fine - Internal Server Error will be spawn.
mysqli_connect('localhost', 'username', 'pass'); 

?>

Hope this helps.

Regards,
Bramus!
 [2009-12-11 16:36 UTC] praveen at aexea dot net
yes, i too downgraded to 5.3.0 because of this issue. I even tried installing a latest snapshot on 25th Nov, but had the same issue..
 [2009-12-11 16:38 UTC] pajoye@php.net
Please disable IPv6 or set localhost correctly in your hosts file (not ::1, as said and explained already a good 100 times here) and try again. Or use 127.0.0.1?
 [2009-12-15 12:15 UTC] instinct644 at googlemail dot com
Id like to add, in Windows Server 2008 R2 the hosts file already had 
both of the lines (127.0.0.1 and ::1) commented already, but it does 
note (# localhost name resolution is handled within DNS itself.)

Un-commenting the line (127.0.0.1       localhost) seems to have fixed 
the issue for now.

Is this going to be fixed in a future PHP release ? Or is it windows ?
 [2009-12-15 12:38 UTC] pajoye@php.net
Doh.

"Un-commenting the line (127.0.0.1       localhost) seems to have fixed the issue for now."

You have to do it. It is not an option.

Same configuration issue, as always > bogus.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Oct 03 13:03:48 2022 UTC