|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50205 Can't start Apache 2.2.14 with PHP 5.2.11
Submitted: 2009-11-17 17:22 UTC Modified: 2009-11-23 19:23 UTC
From: vladmu at mail dot ru Assigned: pajoye (profile)
Status: Not a bug Package: Dynamic loading
PHP Version: 5.2.11 OS: win32 only - Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: vladmu at mail dot ru
New email:
PHP Version: OS:


 [2009-11-17 17:22 UTC] vladmu at mail dot ru
There is a error from windows event viewer:

Faulting application httpd.exe, version, faulting module php5ts.dll, version, fault address 0x000f330d.

Steps to reproduce:

1. Install Apache 2.2.14
2. Stop Apache 2.2 service
3. Install PHP 5.2.11 and select web server Apache 2.2 with defining config path
4. Run Apache 2.2 service


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-18 14:23 UTC]
Please try using this snapshot:
For Windows:

..and remove ALL old dlls and stuff before you do this..
 [2009-11-20 10:28 UTC]
Configuration error, ask on php-setup for support.
 [2009-11-20 19:31 UTC] vladmu at mail dot ru
I don't know this is the configuration error or something else but:

1. I have tried to install a snapshot and there is an equal bug.
2. I have tried to install an Apache 2.2.14 + PHP 5.2.10 and no any errors have occured, and the same was with the Apache 2.2.14 + PHP 5.3.0

Therefore no bogus bug here, but really something wrong with your 5.2.11 libraries for WIndows. Please try to reproduce by yourself at first before change the bug status to bogus.
 [2009-11-21 11:13 UTC]
Disable all extensions in php.ini, check if it works. Then enable one after another to see which one is failing. Many extensions (like DB related) requires clients to be installed and we do not distribute them.
 [2009-11-23 17:00 UTC] vladmu at mail dot ru
So, I have disabled all extensions in php.ini - Apache 2.2.14 works fine with PHP 5.2.11. Then I have enabled one
after another and found the following extensions that block the working:


But after I have uninstalled PHP 5.2.11 and install PHP 5.2.10 only with extensions above and Apache 2.2.14 works fine with PHP 5.2.10 with all "buggly" extensions enabled!
 [2009-11-23 17:03 UTC]
Messing with DLLs, all these extensions require external DLL or clients to be installed.
 [2009-11-23 19:00 UTC] vladmu at mail dot ru
Ok, I agree with this, all these extensions require external DLL or clients to be installed. I have changed a category to "Dynamic loading" because it seems that there is no Apache related bug. But the one question still is not answered, why Apache doesn't work with PHP 5.2.11 when these extensions are enabled but works fine with PHP 5.2.10 and PHP 5.3.0 even if these extensions are enabled? Maybe it will be better to exclude or replace these "bugly" extensions with versions similar to PHP 5.2.10 and PHP 5.3.0?
 [2009-11-23 19:23 UTC]
they work just fine here (10 different windows). As I said, something is wrong in your setup. You ask for further support on the php-windows or php-setup ML.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Dec 01 04:01:29 2023 UTC