php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #502 regular expressions with php3 and apache 1.3.0 (not automatically correct!)
Submitted: 1998-07-02 10:25 UTC Modified: 1998-11-02 10:35 UTC
From: rbock at physik dot uni-kiel dot de Assigned:
Status: Closed Package: Installation problem
PHP Version: 3.0 Final Release OS: Linux 2.0.25 i586
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rbock at physik dot uni-kiel dot de
New email:
PHP Version: OS:

 

 [1998-07-02 10:25 UTC] rbock at physik dot uni-kiel dot de
I had the problem described in FAQ, concerning regular expression core dump with apache.
configure did NOT configure correctly. I had to add the option
--with-system-regex
myself. It therefore seems to me, that the text from FAQ is wrong.

Thank you for your time and of course for PHP3! It is great!

Greetings,

Roland Bock


PS: Here is the mentioned text from FAQ

I installed PHP3, but every time I load a document, I get the message 'Document Contains No Data'! What's going on here? 
   This probably means that PHP3 is having some sort of problem and is core-dumping. Look in your server error log to see if this is the
   case, and then try to reproduce the problem with a small test case. If you know how to use 'gdb', it is very helpful when you can
   provide a backtrace with your bug report to help the developers pinpoint the problem. 

   If your script uses the regular expression functions (ereg() and friends), you should make sure that you compiled PHP3 and Apache
   with the same regular expression package. (This should happen automatically with PHP3 and Apache 1.3.) 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-11-02 10:35 UTC] rasmus
I can't reproduce this problem.  It shouldn't be an issue with any recent Apache-1.3.x
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Oct 03 17:05:53 2022 UTC