php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49977 inability to build the doc howto
Submitted: 2009-10-23 18:17 UTC Modified: 2012-04-06 17:38 UTC
From: philip@php.net Assigned: bjori (profile)
Status: Closed Package: Doc Build problem
PHP Version: 5.3.1RC2 OS: Mac OS X 10.6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
46 + 15 = ?
Subscribe to this entry?

 
 [2009-10-23 18:17 UTC] philip@php.net
Description:
------------
PhD builds the documentation HOWTO. This no longer works properly as of 
PhD 0.9.0/1.0.0.

I'm guessing several fixes are needed with one being the ability to 
disable loadVersionAcronymInfo() here. Maybe HOWTO should be its own 
package? I don't know.

Reproduce code:
---------------
phd -d doc-base/howto/.howto.xml -o howto -f howto -P PHP

Expected result:
----------------
Perfection

Actual result:
--------------
It fails to load version.xml and acronyms.xml, and potentially other 
problems.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-01 19:09 UTC] bjori@php.net
I think we need a package for it as the online howto has some special navigation and headers and footers..
 [2012-04-06 17:38 UTC] bjori@php.net
This seems to be working just fine today..
I've actually no idea how the howto is currently rendered, but it seems to be 
working fine :)
 [2012-04-06 17:38 UTC] bjori@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: bjori
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jul 03 18:03:33 2022 UTC