php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49955 Warning: Unknown: Unable to complete network request
Submitted: 2009-10-22 12:01 UTC Modified: 2011-09-12 09:53 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:1 of 2 (50.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: atendimento at n2g dot com dot br Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.2.11 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: atendimento at n2g dot com dot br
New email:
PHP Version: OS:

 

 [2009-10-22 12:01 UTC] atendimento at n2g dot com dot br
Description:
------------
When testing at my local server I`ve got no errors. Besides, when I send the script to the remote server I've been having this error:

Warning: Unknown: Unable to complete network request to host "200.219.204.106". Error reading data from the connection. Bad file descriptor in Unknown on line 0

I've also tried ibase_connect, but with no results. All my script is working well, but he keeps giving me that error message above.

Reproduce code:
---------------
<?
$conFb = @ibase_pconnect($host, $user, $pass)
         or die("Erro when trying to connect!");
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-22 13:30 UTC] jani@php.net
And you're sure there isn't any firewall in between which might not allow the connection?
 [2009-10-22 13:35 UTC] atendimento at n2g dot com dot br
There's no firewall. Actually, the script is connecting to the database. It retrieves the results correctly. But he gives me that error.

Thank's for replying.
 [2009-10-22 13:37 UTC] jani@php.net
Does something simple like this work:

<?php echo "Hello world!"; ?>
 [2009-10-22 13:55 UTC] atendimento at n2g dot com dot br
I did. And returned the normal result:

Hello world!
 [2009-10-23 10:16 UTC] jani@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.3-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2009-10-23 16:21 UTC] atendimento at n2g dot com dot br
Ok. I've updated my PHP to this version and the error keeps the same. I don't know what else to do!
 [2010-01-11 13:57 UTC] mapopa at gmail dot com
Bug  #49955 http://bugs.php.net/bug.php?id=49955 can be closed , i
have tested with php 5.3 latest snapshot
and firebird is on a remote host
in fact i have tested with two remote hosts one with firebird 2.1 and
one with firebird 2.5
I guess 10000000 connections are enough to see if it's all ok
I got no error , it never reaches to die zone


cat 49955.php
<?
$user='SYSDBA';
$password='masterkey';
$database="192.168.0.1:/var/lib/firebird/2.5/data/employee.fdb";
for ($i = 1; $i <= 10000000; $i++) {
   echo $i;

$conFb = @ibase_pconnect($database, $user, $password)
        or die("Error when trying to connect!");
}
?>


also tested from apache the scripts dies only when it reaches max
execution time , as expected for default php is 30 seconds
lynx http://localhost/49955.php

php versions tested: 5.3.3 snapshot (cli) (built: Jan 11 2010 
13:19:54)

and 5.3.1 rc2 (cli) (built: Nov  2 2009 17:22:21) + apache module
 [2010-01-11 14:26 UTC] mapopa at gmail dot com
also tested with 
PHP 5.2.12 (cli)
 [2010-01-11 17:01 UTC] mapopa at gmail dot com
I have started windows xp in virtualbox and found why it doesn't work 
on windows 

dowloaded the php 5.2.12 http://www.php.net/get/php-5.2.12-
Win32.zip/from/a/mirror
unzip it in c:\php
enable interbase dll extension in php.ini and allow persistent 
connection 

installed firebird 2.1.3 stable from 
http://www.firebirdsql.org/index.php?op=files&id=engine_213

allow the installer to create the lagacy gds32 and firebird client dll 
in system folder 

Delete the old gds32 (interbase 6.0.x dll) from php folder
it's very old and unsupported, this is why it doesn't work on windows 
(persistent connection)

http://picasaweb.google.com/lh/photo/C_I1CJYsyZXrGLtNjDxVTg?
authkey=Gv1sRgCIeMif_wgf2N3wE&feat=directlink
 [2011-09-12 09:53 UTC] mariuz@php.net
-Status: Open +Status: Bogus
 [2011-09-12 09:53 UTC] mariuz@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

seems to be a network issue with that host
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 00:01:23 2020 UTC