php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49925 PhD does not support width and depth attributes for the <imagedata> element
Submitted: 2009-10-19 17:04 UTC Modified: 2009-10-26 14:39 UTC
From: ruslany at microsoft dot com Assigned:
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ruslany at microsoft dot com
New email:
PHP Version: OS:

 

 [2009-10-19 17:04 UTC] ruslany at microsoft dot com
Description:
------------
According to the PhD specification http://www.docbook.org/tdg5/en/html/imagedata.html, the <imagedata> element has width and depth attributes. However, setting those in php documentation does not take any effect.

Reproduce code:
---------------
<mediaobject>
 <imageobject>
  <imagedata fileref="path to file" width="320" depth="240" />
 </imageobject>
</mediaobject>


Expected result:
----------------
The resultant HTML should have:

<img src="path to file" widht="320" height="240" />

Actual result:
--------------
The result HTML has

<img src="path to file" />

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-26 14:38 UTC] svn@php.net
Automatic comment from SVN on behalf of rquadling
Revision: http://svn.php.net/viewvc/?view=revision&revision=289941
Log: Fix bug#49925 : imagedata now supports width and/or depth (becomes width and/or height)
 [2009-10-26 14:39 UTC] rquadling@php.net
This bug has been fixed in SVN. Since the websites are not directly
updated from the SVN server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 21:01:25 2019 UTC