php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #49852 Please Add an spl_autoload_case_sensitivity() Function
Submitted: 2009-10-12 23:11 UTC Modified: 2014-02-27 04:40 UTC
Votes:11
Avg. Score:4.7 ± 0.6
Reproduced:10 of 10 (100.0%)
Same Version:1 (10.0%)
Same OS:4 (40.0%)
From: rahlentertainment at gmail dot com Assigned: levim (profile)
Status: Closed Package: SPL related
PHP Version: 5.2.11 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rahlentertainment at gmail dot com
New email:
PHP Version: OS:

 

 [2009-10-12 23:11 UTC] rahlentertainment at gmail dot com
Description:
------------
Bug #48129, "spl_autoload and case sensitive" was marked as closed/won't fix because changing the behaviour of spl_autoload would break backwards compatibility.

As an alternative, to allow case sensitivity in the future, without breaking existing code, why not add a an spl_autoload_case_sensitivity() function?

The function could take a Boolean value, which enables/disables case sensitivity for spl_autoload, with the default being disabled.

Developers who DO want case-sensitivity can simply call:

spl_autoload_case_sensitivity(true);
spl_autoload("MyClass");



Patches

spl_autoload_case_sensitive (last revision 2010-12-30 00:59 UTC by chris at cmbuckley dot co dot uk)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-24 10:49 UTC] jani@php.net
-Package: Feature/Change Request +Package: SPL related
 [2010-12-30 02:03 UTC] chris at cmbuckley dot co dot uk
Backporting proposed patch by Marc Easen (Bug #53065) to PHP_5_2 branch
 [2011-09-05 01:16 UTC] blake dot soley at gmail dot com
This is still an issue with 5.3.8.  Please fix it, it is basic functionality.  Without it, spl_autoload is broken by any definition.
 [2014-02-27 04:40 UTC] levim@php.net
-Status: Open +Status: Closed -Operating System: Ubuntu Server 8.10/9.04 +Operating System: * -Assigned To: +Assigned To: levim
 [2014-02-27 04:40 UTC] levim@php.net
Closing, but not necessarily rejecting. The RFC process is now the proper way to go about proposing and implementing this functionality, not the bug tracker.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 13:01:26 2020 UTC