php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49743 Problem with functions both procedural and oo
Submitted: 2009-10-02 04:02 UTC Modified: 2009-10-09 05:18 UTC
From: moacir@php.net Assigned:
Status: Closed Package: Doc Build problem
PHP Version: 5.3.0 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: moacir@php.net
New email:
PHP Version: OS:

 

 [2009-10-02 04:02 UTC] moacir@php.net
Description:
------------
PhD 0.9.0 has a problem with functions that are both procedural and oo. The problem is because the indexer stores the docbook_id as primary key, and those functions have two sdesc for one id, so the indexer only stores one of them. Because of this, PhD only links one of the functions.

To solve this problem we could create another table to save the refnames, or use an array like the old mktoc.

Expected result:
----------------
http://php.net/manual/en/mysqli.connect-error.php

Actual result:
--------------
See Also section of:
http://docs.php.net/manual/en/mysqli.connect-error.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-09 05:10 UTC] svn@php.net
Automatic comment from SVN on behalf of moacir
Revision: http://svn.php.net/viewvc/?view=revision&revision=289397
Log: Fixing bug #49743.
- Removing the primary key of docbook_id
- Allowing multiple sdescs
- Links for functions both oo and procedural working again
 [2009-10-09 23:34 UTC] svn@php.net
Automatic comment from SVN on behalf of moacir
Revision: http://svn.php.net/viewvc/?view=revision&revision=289453
Log: Adding notes for the last fixes:
- Bug #45071
- Bug #49743
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Mar 22 22:01:26 2019 UTC