php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4966 Access violation
Submitted: 2000-06-12 00:03 UTC Modified: 2000-08-20 02:08 UTC
From: michael at tapinternet dot com Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.0 Release OS: NT4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michael at tapinternet dot com
New email:
PHP Version: OS:

 

 [2000-06-12 00:03 UTC] michael at tapinternet dot com
I'm getting an 'access violation' whenever I use the mssql_query function - actually, it seems to be 
most functions, except for connecting and selecting_db.  The machine has SP6 I believe (might only be 5), but another one has SP6 and I get the same problem.  

$temp=mssql_connect("SERVER","db1","password");//  or die($phperrmsg);
$db=mssql_select_db("db",$temp)  or die($phperrmsg);
$q=mssql_query("select id from users");

This gives me 

PHP has encountered an Access Violation at 00000000


running

$temp=mssql_connect("SERVER","db1","password");//  or die($phperrmsg);
$db=mssql_select_db("db",$temp)  or die($phperrmsg);
//$q=mssql_query("select id from users");

It works fine, but obviously I don't do anything except connect and select.

Running THIS (with PCONNECT)

$temp=mssql_pconnect("SERVER","db1","password");//  or die($phperrmsg);
//$db=mssql_select_db("db",$temp)  or die($phperrmsg);
//$q=mssql_query("select id from users");

Gives me

PHP has encountered an Access Violation at 73342F43

A wholly different message from before, and ONLY using pconnect - not doing anything else.

The php_mssql70.dll I'm using was from download.swwwing.com build date of 9-6-2000 (june 9, 2000)

Also, the only way I can get the php_mssql70.dll to work AT ALL is to be using the 
PHP Version 4.0.1-dev version from download.swwwing.com as well - the standard distro 
from php.net (w32 binaries) NEVER worked with php_mssql70.dll.

I can't believe I'm the only one with so many problems - the mailing list has people with 
issues similar to this as well it seems.  

Please help!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-26 20:25 UTC] zak@php.net
Have you tried a newer release of php?  If so, has the problem re-occured?
 [2000-08-20 02:08 UTC] sniper@php.net
No feedback from user.

--Jani
 [2004-05-05 16:33 UTC] bruno dot faust at ig dot com dot br
i have the same error in this line:

ocifetchstatement($this->recordset[$this->host], $this->cache[$this->host], false, false, $this->fetch_flag);

$this->recordset[$this->host] = resource
$this->cache[$this->host] = var not isset
$this->fetch_flag = OCI_FETCHSTATEMENT_BY_ROW+OCI_ASSOC

php 4.3.3
PHP API 20020918
PHP Extension 20020429
Zend Extension 20021010
isapi
win nt 4
iis 4
mmcache 2.4.6
extension oci8 $Revision: 1.183.2.5 $

php version 4.3.3 because mmcache.
i?m getting in mmcache enabled ou disabled.
this error did not occur before, nothing was modified in the server.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 05:03:37 2021 UTC