php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49522 Mcrypt Functions
Submitted: 2009-09-10 12:14 UTC Modified: 2009-09-10 13:10 UTC
From: m_cayer_2008 at yahoo dot com Assigned:
Status: Wont fix Package: mcrypt related
PHP Version: 5.3.0 OS: FreeBSD hostingprod.com 4.11-YAH
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: m_cayer_2008 at yahoo dot com
New email:
PHP Version: OS:

 

 [2009-09-10 12:14 UTC] m_cayer_2008 at yahoo dot com
Description:
------------
I am using Yahoo/Geocities web hosting system to learn and try out the PHP features. I tried to use the mcrypt_list_algorithms() function and I get an array with duplicate entries of the algorithms. Each algorithm is listed twice in the array. 

P.S. The PHP version is 4.3. I do not have the ability to upgrade the PHP version because Yahoo/Geocities is control of that and I have requested an upgrade in the past to no avail.

Reproduce code:
---------------
---
From manual page: function.mcrypt-list-algorithms
---
echo "<p> ----- mcrypt_list_algorithms -----</p>";
$algos = mcrypt_list_algorithms( );
print_r( $algos );


Expected result:
----------------
A single entry for each supported algorithm not a duplicate entry.

Actual result:
--------------
----- mcrypt_list_algorithms -----

Array ( [0] => arcfour [1] => arcfour [2] => blowfish-compat [3] => blowfish-compat [4] => blowfish [5] => blowfish [6] => cast-128 [7] => cast-128 [8] => cast-256 [9] => cast-256 [10] => des [11] => des [12] => enigma [13] => enigma [14] => gost [15] => gost [16] => loki97 [17] => loki97 [18] => panama [19] => panama [20] => rc2 [21] => rc2 [22] => rijndael-128 [23] => rijndael-128 [24] => rijndael-192 [25] => rijndael-192 [26] => rijndael-256 [27] => rijndael-256 [28] => safer-sk128 [29] => safer-sk128 [30] => safer-sk64 [31] => safer-sk64 [32] => saferplus [33] => saferplus [34] => serpent [35] => serpent [36] => threeway [37] => threeway [38] => tripledes [39] => tripledes [40] => twofish [41] => twofish [42] => wake [43] => wake [44] => xtea [45] => xtea ) 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-09-10 12:19 UTC] m_cayer_2008 at yahoo dot com
The mcrypt_list_modes() function lists duplicate entries as well.
 [2009-09-10 13:09 UTC] jani@php.net
We are sorry, but we can not support PHP 4 related problems anymore.
Momentum is gathering for PHP 6, and we think supporting PHP 4 will
lead to a waste of resources which we want to put into getting PHP 6
ready.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Aug 12 03:01:27 2020 UTC