php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49293 Call to undefined method com::EnumKey()
Submitted: 2009-08-19 12:09 UTC Modified: 2009-08-19 16:59 UTC
From: lunter at interia dot pl Assigned:
Status: Not a bug Package: COM related
PHP Version: 6SVN-2009-08-19 (snap) OS: WinXP 32-bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lunter at interia dot pl
New email:
PHP Version: OS:

 

 [2009-08-19 12:09 UTC] lunter at interia dot pl
Description:
------------
Bug introduced in PHP 6.0.
PHP 5.3.0 works perfect.


Reproduce code:
---------------
<?
 define('HKEY_LOCAL_MACHINE',0x80000002);
 $wshShell=new COM('winmgmts://./root/default:StdRegProv');
 $wshShell->EnumKey(HKEY_LOCAL_MACHINE,'SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Uninstall',$keys=new VARIANT());
 print(count($keys));
?>


Expected result:
----------------
integer value (try with PHP 5.3.0)

Actual result:
--------------
Fatal error: Call to undefined method com::EnumKey() in C:\htdocs\php6\nod32_sysinspector.php on line

(try with PHP 6 snap)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-19 16:28 UTC] kalle@php.net
Dublicate of #45836, its because theres not any unicode support in com_dotnet yet
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Oct 07 21:03:44 2022 UTC