php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49235 mbstring.func_overload cannot be set via ini_set() or in htaccess
Submitted: 2009-08-12 13:03 UTC Modified: 2009-08-12 18:51 UTC
From: tony at marston-home dot demon dot co dot uk Assigned:
Status: Not a bug Package: mbstring related
PHP Version: 5.2.10 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tony at marston-home dot demon dot co dot uk
New email:
PHP Version: OS:

 

 [2009-08-12 13:03 UTC] tony at marston-home dot demon dot co dot uk
Description:
------------
Cannot set mbstring.func_overload via ini_set(), nor in htaccess

Reproduce code:
---------------
$result1 = ini_set('mbstring.func_overload', 2);  // false
$result2 = ini_get('mbstring.func_overload');     // 0 (should be 2)

Expected result:
----------------
$result2 should be 2 as a result of the previous ini_set().

Actual result:
--------------
ini_get() returns a result of 0 when it should be 2.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-12 13:16 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The setting is PHP_INI_PERDIR which means in .htaccess or in php.ini, the .htaccess method works for me.

ini_set() will not work
 [2009-08-12 18:51 UTC] tony at marston-home dot demon dot co dot uk
mbstring.func_overload cannot be set in htaccess. See bug #49238
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Oct 01 05:05:52 2022 UTC