php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49195 cannot call mysql functions although mysql ext. installed
Submitted: 2009-08-08 05:01 UTC Modified: 2009-08-12 07:26 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: sean dot everlast at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.2SVN-2009-08-08 (snap) OS: Fedora Core 9 2.6.25-14.fc9.i686
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sean dot everlast at gmail dot com
New email:
PHP Version: OS:

 

 [2009-08-08 05:01 UTC] sean dot everlast at gmail dot com
Description:
------------
Fatal error: Call to undefined function mysql_connect() in.....

mysql extension is installed properly. yes, I'm positively 100% sure it 
is.



Reproduce code:
---------------
<?php

mysql_connect("localhost","root","") or die(mysql_error());
mysql_select_db(".....


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-09 14:52 UTC] jani@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2009-08-12 05:14 UTC] erikhartog at yahoo dot com
This error occurred for me on the install of version 5.2.10.  I noticed that my Windows installer did not upgrade the ext directory to the 5.2.10 versions.

Once I manually installed the correct ext libraries all of the files worked.  

It seems the installer was not properly modified.
 [2009-08-12 05:16 UTC] sean dot everlast at gmail dot com
It's really weird, sometimes it's happening, but a server restart gets 
it fixed until the next one.

Since I'm only using PHP for some backend cron jobs, will probably 
switch to perl.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Jun 14 07:01:49 2024 UTC