php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49128 Windows silent install fails with Error 2711
Submitted: 2009-08-01 04:20 UTC Modified: 2009-08-18 20:51 UTC
From: mkucej at yahoo dot com Assigned:
Status: Closed Package: Windows Installer
PHP Version: 5.3.0 OS: Windows XP SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mkucej at yahoo dot com
New email:
PHP Version: OS:

 

 [2009-08-01 04:20 UTC] mkucej at yahoo dot com
Description:
------------
Silent install fails on Windows XP SP2. I tried PHP 5.3.0 and PHP 5.2.10. Silent installation of Apache 2.2.11 works as expected.

Reproduce code:
---------------
msiexec /I php.msi /q INSTALLDIR="C:\Program Files\PHP" APACHEDIR="C:\Program Files\Apache Software Foundation\Apache2.2\conf\" ADDLOCAL=MainExecutable,ScriptExecutable,cgi,apache22,ext_php_pdo_sqlite /L c:\log.txt

Actual result:
--------------
=== Logging started: 7/31/2009  23:04:49 ===
Action start 23:04:49: INSTALL.
Action start 23:04:49: AppSearch.
Action ended 23:04:49: AppSearch. Return value 1.
Action start 23:04:49: LaunchConditions.
Action ended 23:04:49: LaunchConditions. Return value 1.
Action start 23:04:49: FindRelatedProducts.
Action ended 23:04:49: FindRelatedProducts. Return value 1.
Action start 23:04:49: ValidateProductID.
Action ended 23:04:49: ValidateProductID. Return value 1.
Action start 23:04:49: CostInitialize.
Action ended 23:04:49: CostInitialize. Return value 1.
Action start 23:04:49: FileCost.
Action ended 23:04:49: FileCost. Return value 1.
Action start 23:04:49: CostFinalize.
DEBUG: Error 2711:  The specified Feature name ('mainexecutable') not found in Feature Table.
MSI (s) (38:04) [23:04:49:843]: Product: PHP 5.3.0 -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: mainexecutable, , 

The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: mainexecutable, , 
Action ended 23:04:49: CostFinalize. Return value 3.
Action ended 23:04:49: INSTALL. Return value 3.
=== Logging stopped: 7/31/2009  23:04:49 ===


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-02 01:29 UTC] mkucej at yahoo dot com
PHP 5.2.10 thread safe msi installer does not work in silent mode either. The 5.2.9-2 installer works. Here is the log from 5.2.10 failure:

=== Logging started: 8/1/2009  20:23:19 ===
Action start 20:23:19: INSTALL.
Action start 20:23:19: AppSearch.
Action ended 20:23:19: AppSearch. Return value 1.
Action start 20:23:19: LaunchConditions.
Action ended 20:23:19: LaunchConditions. Return value 1.
Action start 20:23:19: FindRelatedProducts.
Action ended 20:23:19: FindRelatedProducts. Return value 1.
Action start 20:23:19: ValidateProductID.
Action ended 20:23:19: ValidateProductID. Return value 1.
Action start 20:23:19: CostInitialize.
Action ended 20:23:19: CostInitialize. Return value 1.
Action start 20:23:19: FileCost.
Action ended 20:23:19: FileCost. Return value 1.
Action start 20:23:19: CostFinalize.
DEBUG: Error 2711:  The specified Feature name ('MainExecutable') not found in Feature Table.
MSI (s) (68:2C) [20:23:19:656]: Product: PHP 5.2.10 -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: MainExecutable, , 

The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: MainExecutable, , 
Action ended 20:23:19: CostFinalize. Return value 3.
Action ended 20:23:19: INSTALL. Return value 3.
=== Logging stopped: 8/1/2009  20:23:19 ===
 [2009-08-18 20:45 UTC] jmertic@php.net
The MainExecutable feature is no longer there since by default we install the php.exe file always now ( behavior changed in 5.2.10/5.3.0 )
 [2009-08-18 20:51 UTC] jmertic@php.net
Documentation added in SVN.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Oct 03 19:03:44 2022 UTC