php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49094 Can't parse WSDL
Submitted: 2009-07-29 08:11 UTC Modified: 2009-08-03 08:16 UTC
Votes:3
Avg. Score:3.3 ± 1.7
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: kelvin at netbasic dot co dot uk Assigned:
Status: Closed Package: SOAP related
PHP Version: 5.3.0 OS: Centos 4.7 and 5.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kelvin at netbasic dot co dot uk
New email:
PHP Version: OS:

 

 [2009-07-29 08:11 UTC] kelvin at netbasic dot co dot uk
Description:
------------
PHP 5.3 is having issues parsing the WSDL for certain webservices and 
throwing an exception stating there is additional content at the end, 
but the same webservice works in 5.2.10.

Reproduce code:
---------------
<?php
     $url = "https://ews31.marketing.ews.yahooapis.com:443/services/V5/CampaignService?wsdl";

     echo "Start client..";
     $client = new SoapClient($url);
     echo "Finish client..";
?>


Expected result:
----------------
Start client..
Finish client..

Actual result:
--------------
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing 
WSDL: Couldn't load from 
'https://ews31.marketing.ews.yahooapis.com:443/services/V5/CampaignServi
ce?wsdl' : Extra content at the end of the document in 
/usr/local/apache/htdocs/t2.php:7 Stack trace: #0 
/usr/local/apache/htdocs/t2.php(7): SoapClient-
>SoapClient('https://ews31.m...', Array) #1 {main} thrown in 
/usr/local/apache/htdocs/t2.php on line 7

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-03 08:16 UTC] kelvin at netbasic dot co dot uk
Hi Guys

I've tested the latest snapshot and it appear to fix this, I believe its 
related to this bug http://bugs.php.net/bug.php?id=49014.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 26 12:01:29 2024 UTC