php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49035 Fatal error: Class 'COM' not found
Submitted: 2009-07-23 15:30 UTC Modified: 2009-07-23 22:55 UTC
From: parviz_ahmadi at yahoo dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 5.2.10 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: parviz_ahmadi at yahoo dot com
New email:
PHP Version: OS:

 

 [2009-07-23 15:30 UTC] parviz_ahmadi at yahoo dot com
Description:
------------
Dear Sir/ Madam,
what is solution in PHP5 if There is no COM extension in PHP 5 for creating object below :
$browser = new COM("InternetExplorer.Application");
Also my host operating system in linux and php 5.2.9 .
Thank you.
Parviz.

Reproduce code:
---------------
---
<?php
set_time_limit(2000) ;
$browser = new COM("InternetExplorer.Application") or die("Unable to instantiate COM");
$handle = $browser->HWND;
$browser->Visible = true;
$browser->Fullscreen = true;
$browser->Navigate("http://www.libgd.org");

/* Still working? */
while ($browser->Busy) {
    com_message_pump(4000);
}
$im = imagegrabwindow($handle, 0);
$browser->Quit();
imagepng($im, "iesnap.png");
imagedestroy($im);
?> ---


Actual result:
--------------
Fatal error: Class 'COM' not found in ***/test.php on line 3


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-23 22:55 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 04:05:53 2022 UTC