php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49030 fails to resolve cyclic references
Submitted: 2009-07-23 11:03 UTC Modified: 2009-07-23 22:55 UTC
From: markus at malkusch dot de Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.1.6 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: markus at malkusch dot de
New email:
PHP Version: OS:

 

 [2009-07-23 11:03 UTC] markus at malkusch dot de
Description:
------------
I must say I'm using php 5.1.6. I'm not able to upgrade the version in this environment. As I didn't find any comments on my problem, I assume it's still in PHP.

I have some segfaults with a certain SOAP-answer. I decided to use PEAR-Soap instead. It doesn't work with pear neither. It turns out, that this special answer uses cyclic object references and PEAR::Soap cannot handle that. I assume PHP's Soap has the same problems.

Reproduce code:
---------------
This is only an excerpt of the SOAP-Answer:

    <env:Body>
        <ns0:Paragraph id="ID19" xsi:type="ns0:Paragraph">
            <sub href="#ID21" />
        </ns0:Paragraph>
        <ns0:Paragraph id="ID21" xsi:type="ns0:Paragraph">
            <parent href="#ID19" />
        </ns0:Paragraph>
    </env:Body>

Expected result:
----------------
I expect an object graph with correct cyclic references.

Actual result:
--------------
Apache segfaults now. I think this is due to an infinit loop like PEAR does as well.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-23 22:55 UTC] jani@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 03:03:33 2021 UTC