php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48873 Using both --with-libedit and --with-readline cause unknown option warning
Submitted: 2009-07-09 15:58 UTC Modified: 2010-12-20 12:45 UTC
From: simon at stienen dot name Assigned: jani (profile)
Status: Closed Package: Compile Warning
PHP Version: 5.*, 6CVS (2009-07-09) OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: simon at stienen dot name
New email:
PHP Version: OS:

 

 [2009-07-09 15:58 UTC] simon at stienen dot name
Description:
------------
./configure lists:

-- snip --
  --with-libedit[=DIR]    Include libedit readline replacement (CLI/CGI only)
  --with-readline[=DIR]   Include readline support (CLI/CGI only)
  --with-recode[=DIR]     Include recode support
-- snip --


Reproduce code:
---------------
./configure --prefix=/usr/local --exec-prefix=/usr/local --localstatedir=/var --with-apxs2filter --with-pcre-regex --with-zlib --enable-bcmath --with-bz2 --with-curl --with-curlwrappers --enable-exif --with-gd --with-jpeg-dir --with-png-dir --with-zlib-dir --with-xpm-dir --with-freetype-dir --with-t1lib --enable-gd-native-ttf --enable-gd-jis-conv --with-gettext --with-gmp --with-mhash --with-imap --with-kerberos --with-imap-ssl --enable-intl --with-ldap --enable-mbstring --with-onig --with-mcrypt --with-mysql=mysqlnd --with-mysqli=mysqlnd --enable-pcntl --with-pdo-mysql=mysqlnd --with-zlib-dir --with-readline --with-libedit --enable-shmop --enable-soap --enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm --with-tidy --enable-wddx --with-xmlrpc --with-xsl --enable-zip --enable-mysqlnd-threading

Expected result:
----------------
Expecting no error message.

Actual result:
--------------
Notice: Following unknown configure options were used:

--with-readline

Check './configure --help' for available options


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-09 19:50 UTC] jani@php.net
It's because you used both --with-libedit and --with-readline. You 
should use either or. I'll try see if there's some easy way to fix it.
 [2009-08-03 11:21 UTC] svn@php.net
Automatic comment from SVN on behalf of jani
Revision: http://svn.php.net/viewvc/?view=revision&revision=286725
Log: - Fixed bBug #48873 (Using both --with-libedit and --with-readline cause unknown option warning)

# This isn't worth of NEWS entry, it's just cosmetic
 [2009-08-03 11:21 UTC] jani@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2010-12-20 12:45 UTC] jani@php.net
-Package: Tidy +Package: Compile Warning
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Dec 10 06:05:52 2022 UTC