php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48837 Building --with-curlwrappers can cause bad/illegal format or missing URL errors
Submitted: 2009-07-07 16:59 UTC Modified: 2009-07-10 21:56 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ramsey@php.net Assigned: fb-req-jani (profile)
Status: Not a bug Package: cURL related
PHP Version: 5.3.0 OS: Ubuntu 9.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ramsey@php.net
New email:
PHP Version: OS:

 

 [2009-07-07 16:59 UTC] ramsey@php.net
Description:
------------
I received the error "URL using bad/illegal format or missing URL" on some require_once() calls when PHP was built with --with-curlwrappers.

Building PHP without --with-curlwrappers fixed the problem.

Reproduce code:
---------------
I was using a vanilla install of Zend Framework when I noticed the problem.

Expected result:
----------------
The file did exist at the location being required, and the include_path was correct, so I expected the file to be required.

Actual result:
--------------
Warning: require_once(): URL using bad/illegal format or missing URL in /home/ramsey/dev/zftest/lib/Zend/Loader/PluginLoader.php on line 396 Warning: require_once(/home/ramsey/dev/zftest/lib/Zend/Loader/PluginLoader/Exception.php): failed to open stream: operation failed in /home/ramsey/dev/zftest/lib/Zend/Loader/PluginLoader.php on line 396 Fatal error: require_once(): Failed opening required 'Zend/Loader/PluginLoader/Exception.php' (include_path='/home/ramsey/dev/zftest/lib') in /home/ramsey/dev/zftest/lib/Zend/Loader/PluginLoader.php on line 396

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-07 17:17 UTC] jani@php.net
Does this happen with PHP 5.2.10?
 [2009-07-07 18:36 UTC] ramsey@php.net
Oddly enough, I cannot reproduce this now in 5.3.0 or 5.2.10, though I was having this problem the other day. When I build either version with --with-curlwrappers and use the same code I used the other day, it appears to work fine now. As far as I know, nothing else on the system has changed in the meantime.

I guess you can feel free to bogus this issue, since I can't reproduce it.
 [2009-07-08 18:15 UTC] jd at cpanel dot net
Probably the same issue as:

http://bugs.php.net/bug.php?id=48603

It looks like when safe_mode or open_basedir are enabled and php is compiled with curlwrappers, curlwrappers registers the curl extension to handle file streams and then php_curl_option_url() in interface.c tells libcurl not to handle file requests.

The "URL using bad/illegal format or missing URL" error message comes from libcurl itself.
 [2009-07-10 21:56 UTC] jani@php.net
As requested.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Dec 10 02:01:24 2018 UTC