php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48813 used ob_start() and CPU usage become 100%
Submitted: 2009-07-06 10:46 UTC Modified: 2009-07-15 01:00 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: manju_kalita at infosys dot com Assigned: fb-req-jani (profile)
Status: No Feedback Package: *General Issues
PHP Version: 5.3.0 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: manju_kalita at infosys dot com
New email:
PHP Version: OS:

 

 [2009-07-06 10:46 UTC] manju_kalita at infosys dot com
Description:
------------
I have used:
ob_start(); #at the starting of the scipt

ob_flush();
ob_end_clean(); # at the end of the script

everything working fine. But when I go to next page and do a IE back, sometime the CPU utilization reached 100% in client system and the IE got crashed.sometime its work perfectly.
In any other script, we are not using ob_start() or ob_flush(). 

Please let me know how can we manage the memory utilization to prevent this issue.

Expected result:
----------------
IE back sud work and CPU utilization should not reach so high.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-06 12:41 UTC] jani@php.net
Does this happen with PHP 5.2.10 ?
 [2009-07-06 13:11 UTC] manju_kalita at infosys dot com
Its PHP5.0 version
 [2009-07-07 17:24 UTC] jani@php.net
Exactly WHAT PHP version are you having this problem with?
 [2009-07-15 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2009-10-29 08:06 UTC] karamveer dot singh at smartbuzz dot net
hi all ,
i am also facing this problem. I am using 4.4.7 version of php at linux server .Our server admn reply me that sometime your some pages reached 100% CPU utilization due to some script running on  site.So please help me.sorry for bad english.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 02:01:35 2024 UTC