php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48794 Unclosed array keys break space escaping in $_GET/POST/REQUEST
Submitted: 2009-07-03 18:55 UTC Modified: 2015-07-29 19:05 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: tolkad dot freenode at gmail dot com Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 5.2.10 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tolkad dot freenode at gmail dot com
New email:
PHP Version: OS:

 

 [2009-07-03 18:55 UTC] tolkad dot freenode at gmail dot com
Description:
------------
PHP normally replaces spaces, periods, and unclosed [ with underscores in $_GET/$_POST/$_REQUEST. After an unclosed [, it ceases to do this.

Reproduce code:
---------------
/*
With a url like ?x[ x=x
*/
print_r($_GET);

Expected result:
----------------
Array
(
    [x__x] => x
)


Actual result:
--------------
Array
(
    [x_ x] => x
)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-04 22:21 UTC] jani@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

See bug #48597
 [2015-07-29 19:05 UTC] cmb@php.net
-Status: Not a bug +Status: Duplicate
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC