php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48625 cannot open phar "/path/php-5.2.10/pear/install-pear-nozlib.phar"
Submitted: 2009-06-21 03:28 UTC Modified: 2009-07-10 22:00 UTC
Votes:18
Avg. Score:4.7 ± 0.6
Reproduced:16 of 16 (100.0%)
Same Version:16 (100.0%)
Same OS:9 (56.2%)
From: filebackup at 126 dot com Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.2.10 OS: centos5.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: filebackup at 126 dot com
New email:
PHP Version: OS:

 

 [2009-06-21 03:28 UTC] filebackup at 126 dot com
Description:
------------
Hi,
  I had happened an error when I 'make install' php5.2.10.
I make it like so:
tar zxvf php-5.2.10.tar.gz
gzip -cd php-5.2.10-fpm-0.5.11.diff.gz | patch -d php-5.2.10 -p1
cd php-5.2.10/
./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php/etc --with-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --with-iconv-dir=/usr/local --with-freetype-dir --with-jpeg-dir --with-png-dir --with-zlib --with-libxml-dir=/usr --enable-xml --disable-rpath --enable-discard-path --enable-safe-mode --enable-bcmath --enable-shmop --enable-sysvsem --enable-inline-optimization --enable-mbregex --enable-fastcgi --enable-fpm --enable-force-cgi-redirect --enable-mbstring --with-mcrypt --with-gd --enable-gd-native-ttf --with-openssl --with-mhash --enable-pcntl --enable-sockets --disable-ipv6 --with-xmlrpc --enable-zip --without-sqlite --with-xpm-dir=/usr --with-curl=/usr/local --with-curlwrappers --enable-static
make ZEND_EXTRA_LIBS='-liconv'
make install


When I "make ZEND_EXTRA_LIBS='-liconv'", nothing display.
But when I "make install", it would display the next error information:
Fatal error: Error: cannot open phar "/root/soft/php-5.2.10/pear/install-pear-nozlib.phar" in /path/php-5.2.10/pear/install-pear-nozlib.phar on line 795
make[1]: *** [install-pear-installer] Error 255
make: *** [install-pear] Error 2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-21 03:33 UTC] filebakck at 126 dot com
But I can compile php5.2.8 or php 5.2.9.
 [2009-06-21 03:35 UTC] filebakck at 126 dot com
"/root/soft/php-5.2.10/pear/install-pear-nozlib.phar"

It's "/path/php-5.2.10/pear/install-pear-nozlib.phar".
 [2009-06-21 03:48 UTC] filebackup at 126 dot com
gcc-4.1.2-44.el5
centos5.3 x86_64
 [2009-06-22 16:50 UTC] newsletter at rrelmy dot ch
same on debian lenny 2.6.26-2-vserver-amd64
and debian lenny 2.6.30 (64Bit system)
both used gcc 4.3.2

all versions before worked with the same configuration

./configure --prefix=/etc/php5 --with-apxs2=/usr/bin/apxs2 --enable-bcmath --enable-calendar --with-curl --with-curlwrappers --with-freetype-dir=/usr/lib/ --enable-ftp --with-gd --enable-gd-jis-conv --enable-gd-native-ttf --with-jpeg-dir=/usr/lib/ --enable-libxml --with-libxml-dir=/usr/lib --enable-magic-quotes --enable-mbstring=all --with-mcrypt --with-mhash --with-mime-magic --with-mysql --with-openssl --with-pdo-mysql --with-png-dir=/usr/include --disable-posix --enable-simplexml --enable-sqlite-utf8 --with-ttf --with-zlib --with-bz2 --with-tidy --with-xpm-dir=/usr/lib/ --with-t1lib=/usr/lib --with-gettext
 [2009-06-22 23:56 UTC] mlavi at sgi dot com
Appears to be a duplicate of bugs: 48603 and 48650.
http://bugs.php.net/bug.php?id=48603
http://bugs.php.net/bug.php?id=48650
 [2009-06-29 00:42 UTC] wjones at tchd dot biz
This is also happening on CentOS 4.7, 5.2, and 5.3
 [2009-07-10 22:00 UTC] jani@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 02:01:24 2020 UTC