php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48615 Will not install. Exits with error 2711
Submitted: 2009-06-20 12:58 UTC Modified: 2010-03-25 19:05 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: codeblock at eighthbit dot net Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 6CVS-2009-06-20 (snap) OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: codeblock at eighthbit dot net
New email:
PHP Version: OS:

 

 [2009-06-20 12:58 UTC] codeblock at eighthbit dot net
Description:
------------
The installer exits with error 2711, when trying to install with the apache 2.x module. 5.3 snap installed fine.

Expected result:
----------------
Installer to continue.

Actual result:
--------------
Installer exits with error code 2711.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-28 18:24 UTC] jmertic@php.net
Could you run it in verbose logging mode and attach the log file? To
run
in verbose logging mode issue the below command from the command prompt
( from the same directory where the install exists ):

msiexec /i php-6.0.0-win32-installer.msi /l*v error.log
 [2009-07-06 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2009-10-30 21:46 UTC] stevek at promanagementsystems dot com
MSI (s) (E4:44) [16:42:22:686]: PROPERTY CHANGE: Modifying INSTALLDIR property. Its current value is 'c:\php'. Its new value: 'C:\php\'.
MSI (s) (E4:44) [16:42:22:686]: PROPERTY CHANGE: Adding extrasdirectory property. Its value is 'C:\php\extras\'.
MSI (s) (E4:44) [16:42:22:686]: PROPERTY CHANGE: Adding extdirectory property. Its value is 'C:\php\ext\'.
MSI (s) (E4:44) [16:42:22:686]: PROPERTY CHANGE: Adding devdirectory property. Its value is 'C:\php\dev\'.
MSI (s) (E4:44) [16:42:22:686]: Target path resolution complete. Dumping Directory table...
MSI (s) (E4:44) [16:42:22:686]: Note: target paths subject to change (via custom actions or browsing)
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: TARGETDIR	, Object: F:\
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: XITAMIDIR	, Object: NULL
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: WindowsFolder	, Object: C:\WINDOWS\
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: ProgramMenuFolder	, Object: C:\Documents and Settings\All Users\Start Menu\Programs\
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: ProgramMenuDir	, Object: C:\Documents and Settings\All Users\Start Menu\Programs\PHP 5\
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: ProgramFilesFolder	, Object: C:\Program Files\
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: INSTALLDIR	, Object: C:\php\
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: extrasdirectory	, Object: C:\php\extras\
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: extdirectory	, Object: C:\php\ext\
MSI (s) (E4:44) [16:42:22:686]: Dir (target): Key: devdirectory	, Object: C:\php\dev\
MSI (s) (E4:44) [16:42:22:686]: PROPERTY CHANGE: Adding INSTALLLEVEL property. Its value is '1'.
MSI (s) (E4:44) [16:42:22:702]: Note: 1: 2711 2: APACHEDIR=c:\apache 
MSI (s) (E4:44) [16:42:22:702]: Note: 1: 2205 2:  3: Error 
MSI (s) (E4:44) [16:42:22:702]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 2711 
DEBUG: Error 2711:  The specified Feature name ('APACHEDIR=c:\apache') not found in Feature Table.
MSI (s) (E4:44) [16:42:22:717]: Note: 1: 2205 2:  3: Error 
MSI (s) (E4:44) [16:42:22:717]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
MSI (s) (E4:44) [16:42:22:733]: Product: PHP 5.3.0 -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: APACHEDIR=c:\apache, , 

The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: APACHEDIR=c:\apache, , 
Action ended 16:42:22: CostFinalize. Return value 3.
Action ended 16:42:22: INSTALL. Return value 3.
Property(S): INSTALLDIR = C:\php\
 [2010-01-01 15:47 UTC] uwe_markus at hotmail dot com
=== Verbose logging started: 01.01.2010  16:42:56  Build type: SHIP 
UNICODE 5.00.7600.00  Calling process: C:\Windows\system32\msiexec.exe 
===
MSI (c) (0C:44) [16:42:56:672]: Font created.  Charset: Req=0, Ret=0, 
Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (0C:44) [16:42:56:672]: Font created.  Charset: Req=0, Ret=0, 
Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (0C:A0) [16:42:56:703]: Resetting cached policy values
MSI (c) (0C:A0) [16:42:56:703]: Machine policy value 'Debug' is 0
MSI (c) (0C:A0) [16:42:56:703]: ******* RunEngine:
           ******* Product: php-5.3-nts-win32-VC9-x64-latest.msi
           ******* Action: 
           ******* CommandLine: **********
MSI (c) (0C:A0) [16:42:56:703]: Machine policy value 
'DisableUserInstalls' is 0
MSI (c) (0C:A0) [16:42:56:719]: Note: 1: 1402 2: 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\E
xplorer 3: 2 
MSI (c) (0C:A0) [16:42:56:719]: SOFTWARE RESTRICTION POLICY: Verifying 
package --> 'C:\Users\Administrator\Desktop\PHP\php-5.3-nts-win32-VC9-
x64-latest.msi' against software restriction policy
MSI (c) (0C:A0) [16:42:56:719]: Note: 1: 2262 2: DigitalSignature 3: -
2147287038 
MSI (c) (0C:A0) [16:42:56:719]: SOFTWARE RESTRICTION POLICY: 
C:\Users\Administrator\Desktop\PHP\php-5.3-nts-win32-VC9-x64-
latest.msi is not digitally signed
MSI (c) (0C:A0) [16:42:56:719]: SOFTWARE RESTRICTION POLICY: 
C:\Users\Administrator\Desktop\PHP\php-5.3-nts-win32-VC9-x64-
latest.msi is permitted to run at the 'unrestricted' authorization 
level.
MSI (c) (0C:A0) [16:42:56:719]: Cloaking enabled.
MSI (c) (0C:A0) [16:42:56:719]: Attempting to enable all disabled 
privileges before calling Install on Server
MSI (c) (0C:A0) [16:42:56:734]: End dialog not enabled
MSI (c) (0C:A0) [16:42:56:734]: Original package ==> 
C:\Users\Administrator\Desktop\PHP\php-5.3-nts-win32-VC9-x64-
latest.msi
MSI (c) (0C:A0) [16:42:56:734]: Package we're running from ==> 
C:\Users\Administrator\Desktop\PHP\php-5.3-nts-win32-VC9-x64-
latest.msi
MSI (c) (0C:A0) [16:42:56:734]: APPCOMPAT: Compatibility mode property 
overrides found.
MSI (c) (0C:A0) [16:42:56:734]: APPCOMPAT: looking for appcompat 
database entry with ProductCode '{C9E68706-081D-4302-8EED-
309849864DA7}'.
MSI (c) (0C:A0) [16:42:56:734]: APPCOMPAT: no matching ProductCode 
found in database.
MSI (c) (0C:A0) [16:42:56:750]: MSCOREE not loaded loading copy from 
system32
MSI (c) (0C:A0) [16:42:56:750]: Machine policy value 
'TransformsSecure' is 1
MSI (c) (0C:A0) [16:42:56:750]: Machine policy value 'DisablePatch' is 
0
MSI (c) (0C:A0) [16:42:56:750]: Machine policy value 
'AllowLockdownPatch' is 0
MSI (c) (0C:A0) [16:42:56:750]: Machine policy value 
'DisableLUAPatching' is 0
MSI (c) (0C:A0) [16:42:56:750]: Machine policy value 
'DisableFlyWeightPatching' is 0
MSI (c) (0C:A0) [16:42:56:750]: APPCOMPAT: looking for appcompat 
database entry with ProductCode '{C9E68706-081D-4302-8EED-
309849864DA7}'.
MSI (c) (0C:A0) [16:42:56:750]: APPCOMPAT: no matching ProductCode 
found in database.
MSI (c) (0C:A0) [16:42:56:750]: Transforms are not secure.
MSI (c) (0C:A0) [16:42:56:750]: PROPERTY CHANGE: Adding 
MsiLogFileLocation property. Its value is 
'C:\Users\Administrator\Desktop\PHP\error.log'.
MSI (c) (0C:A0) [16:42:56:750]: Command Line: 
CURRENTDIRECTORY=C:\Users\Administrator\Desktop\PHP CLIENTUILEVEL=0 
CLIENTPROCESSID=2572 
MSI (c) (0C:A0) [16:42:56:750]: PROPERTY CHANGE: Adding PackageCode 
property. Its value is '{DC36AD73-169E-41EC-8C45-016D75DA70E4}'.
MSI (c) (0C:A0) [16:42:56:750]: Product Code passed to 
Engine.Initialize:           ''
MSI (c) (0C:A0) [16:42:56:750]: Product Code from property table 
before transforms: '{C9E68706-081D-4302-8EED-309849864DA7}'
MSI (c) (0C:A0) [16:42:56:750]: Product Code from property table after 
transforms:  '{C9E68706-081D-4302-8EED-309849864DA7}'
MSI (c) (0C:A0) [16:42:56:750]: Product not registered: beginning 
first-time install
MSI (c) (0C:A0) [16:42:56:750]: PROPERTY CHANGE: Adding ProductState 
property. Its value is '-1'.
MSI (c) (0C:A0) [16:42:56:750]: Entering 
CMsiConfigurationManager::SetLastUsedSource.
MSI (c) (0C:A0) [16:42:56:750]: User policy value 'SearchOrder' is 
'nmu'
MSI (c) (0C:A0) [16:42:56:750]: Adding new sources is allowed.
MSI (c) (0C:A0) [16:42:56:750]: PROPERTY CHANGE: Adding 
PackagecodeChanging property. Its value is '1'.
MSI (c) (0C:A0) [16:42:56:750]: Package name extracted from package 
path: 'php-5.3-nts-win32-VC9-x64-latest.msi'
MSI (c) (0C:A0) [16:42:56:750]: Package to be registered: 'php-5.3-
nts-win32-VC9-x64-latest.msi'
MSI (c) (0C:A0) [16:42:56:750]: Note: 1: 2205 2:  3: Error 
MSI (c) (0C:A0) [16:42:56:750]: Note: 1: 2262 2: AdminProperties 3: -
2147287038 
MSI (c) (0C:A0) [16:42:56:750]: Machine policy value 'DisableMsi' is 1
MSI (c) (0C:A0) [16:42:56:750]: Machine policy value 
'AlwaysInstallElevated' is 0
MSI (c) (0C:A0) [16:42:56:750]: User policy value 
'AlwaysInstallElevated' is 0
MSI (c) (0C:A0) [16:42:56:750]: Product installation will be elevated 
because user is admin and product is being installed per-machine.
MSI (c) (0C:A0) [16:42:56:750]: Running product '{C9E68706-081D-4302-
8EED-309849864DA7}' with elevated privileges: Product is assigned.
MSI (c) (0C:A0) [16:42:56:750]: PROPERTY CHANGE: Adding 
CURRENTDIRECTORY property. Its value is 
'C:\Users\Administrator\Desktop\PHP'.
MSI (c) (0C:A0) [16:42:56:750]: PROPERTY CHANGE: Adding CLIENTUILEVEL 
property. Its value is '0'.
MSI (c) (0C:A0) [16:42:56:750]: PROPERTY CHANGE: Adding 
CLIENTPROCESSID property. Its value is '2572'.
MSI (c) (0C:A0) [16:42:56:750]: PROPERTY CHANGE: Adding 
MsiSystemRebootPending property. Its value is '1'.
MSI (c) (0C:A0) [16:42:56:750]: TRANSFORMS property is now: 
MSI (c) (0C:A0) [16:42:56:750]: PROPERTY CHANGE: Adding 
VersionDatabase property. Its value is '100'.
MSI (c) (0C:A0) [16:42:56:750]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming
MSI (c) (0C:A0) [16:42:56:750]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\Favorites
MSI (c) (0C:A0) [16:42:56:750]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Network 
Shortcuts
MSI (c) (0C:A0) [16:42:56:750]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\Documents
MSI (c) (0C:A0) [16:42:56:750]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Printer 
Shortcuts
MSI (c) (0C:A0) [16:42:56:750]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Recent
MSI (c) (0C:A0) [16:42:56:750]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\SendTo
MSI (c) (0C:A0) [16:42:56:750]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Templates
MSI (c) (0C:A0) [16:42:56:750]: SHELL32::SHGetFolderPath returned: 
C:\ProgramData
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Local
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\Pictures
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative 
Tools
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\ProgramData\Microsoft\Windows\Start Menu\Programs
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\ProgramData\Microsoft\Windows\Start Menu
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\Users\Public\Desktop
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Start 
Menu\Programs\Administrative Tools
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Start 
Menu\Programs\Startup
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Start 
Menu\Programs
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Start Menu
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\Users\Administrator\Desktop
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\ProgramData\Microsoft\Windows\Templates
MSI (c) (0C:A0) [16:42:56:766]: SHELL32::SHGetFolderPath returned: 
C:\Windows\Fonts
MSI (c) (0C:A0) [16:42:56:766]: Note: 1: 2898 2: MS Sans Serif 3: MS 
Sans Serif 4: 0 5: 16 
MSI (c) (0C:A0) [16:42:56:766]: MSI_LUA: Setting AdminUser property to 
1 because this is the client or the user has already permitted 
elevation
MSI (c) (0C:A0) [16:42:56:766]: MSI_LUA: Setting MsiRunningElevated 
property to 1 because the install is already running elevated.
MSI (c) (0C:A0) [16:42:56:766]: PROPERTY CHANGE: Adding 
MsiRunningElevated property. Its value is '1'.
MSI (c) (0C:A0) [16:42:56:766]: PROPERTY CHANGE: Adding Privileged 
property. Its value is '1'.
MSI (c) (0C:A0) [16:42:56:766]: Note: 1: 1402 2: 
HKEY_CURRENT_USER\Software\Microsoft\MS Setup (ACME)\User Info 3: 2 
MSI (c) (0C:A0) [16:42:56:766]: PROPERTY CHANGE: Adding USERNAME 
property. Its value is 'Windows-Benutzer'.
MSI (c) (0C:A0) [16:42:56:766]: Note: 1: 1402 2: 
HKEY_CURRENT_USER\Software\Microsoft\MS Setup (ACME)\User Info 3: 2 
MSI (c) (0C:A0) [16:42:56:766]: PROPERTY CHANGE: Adding DATABASE 
property. Its value is 'C:\Users\Administrator\Desktop\PHP\php-5.3-
nts-win32-VC9-x64-latest.msi'.
MSI (c) (0C:A0) [16:42:56:766]: PROPERTY CHANGE: Adding 
OriginalDatabase property. Its value is 
'C:\Users\Administrator\Desktop\PHP\php-5.3-nts-win32-VC9-x64-
latest.msi'.
MSI (c) (0C:A0) [16:42:56:766]: Machine policy value 
'MsiDisableEmbeddedUI' is 0
MSI (c) (0C:A0) [16:42:56:766]: PROPERTY CHANGE: Adding SourceDir 
property. Its value is 'C:\Users\Administrator\Desktop\PHP\'.
MSI (c) (0C:A0) [16:42:56:766]: PROPERTY CHANGE: Adding SOURCEDIR 
property. Its value is 'C:\Users\Administrator\Desktop\PHP\'.
MSI (c) (0C:44) [16:42:56:766]: PROPERTY CHANGE: Adding VersionHandler 
property. Its value is '5.00'.
=== Logging started: 01.01.2010  16:42:56 ===
MSI (c) (0C:A0) [16:42:56:781]: Note: 1: 2205 2:  3: PatchPackage 
MSI (c) (0C:A0) [16:42:56:781]: Machine policy value 'DisableRollback' 
is 0
MSI (c) (0C:A0) [16:42:56:781]: User policy value 'DisableRollback' is 
0
MSI (c) (0C:A0) [16:42:56:781]: PROPERTY CHANGE: Adding UILevel 
property. Its value is '5'.
MSI (c) (0C:A0) [16:42:56:781]: PROPERTY CHANGE: Adding ACTION 
property. Its value is 'INSTALL'.
MSI (c) (0C:A0) [16:42:56:781]: Doing action: INSTALL
MSI (c) (0C:A0) [16:42:56:781]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: INSTALL. 
Action start 16:42:56: INSTALL.
MSI (c) (0C:A0) [16:42:56:781]: UI Sequence table 'InstallUISequence' 
is present and populated.
MSI (c) (0C:A0) [16:42:56:781]: Running UISequence
MSI (c) (0C:A0) [16:42:56:781]: PROPERTY CHANGE: Adding EXECUTEACTION 
property. Its value is 'INSTALL'.
MSI (c) (0C:A0) [16:42:56:781]: Doing action: 
WindowsFolder.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_
D7AD_3E2F_9ACB_44D8D43BD919
MSI (c) (0C:A0) [16:42:56:781]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: 
WindowsFolder.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_
D7AD_3E2F_9ACB_44D8D43BD919. 
Action start 16:42:56: 
WindowsFolder.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_
D7AD_3E2F_9ACB_44D8D43BD919.
MSI (c) (0C:A0) [16:42:56:781]: Note: 1: 2235 2:  3: ExtendedType 4: 
SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM 
`CustomAction` WHERE `Action` = 
'WindowsFolder.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A
_D7AD_3E2F_9ACB_44D8D43BD919' 
MSI (c) (0C:A0) [16:42:56:781]: PROPERTY CHANGE: Adding 
WindowsFolder.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_
D7AD_3E2F_9ACB_44D8D43BD919 property. Its value is 'C:\Windows\'.
Action ended 16:42:56: 
WindowsFolder.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_
D7AD_3E2F_9ACB_44D8D43BD919. Return value 1.
MSI (c) (0C:A0) [16:42:56:781]: Doing action: 
WindowsFolder.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B
886_7BAABC047B61
MSI (c) (0C:A0) [16:42:56:781]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: 
WindowsFolder.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B
886_7BAABC047B61. 
Action start 16:42:56: 
WindowsFolder.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B
886_7BAABC047B61.
MSI (c) (0C:A0) [16:42:56:781]: Note: 1: 2235 2:  3: ExtendedType 4: 
SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM 
`CustomAction` WHERE `Action` = 
'WindowsFolder.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_
B886_7BAABC047B61' 
MSI (c) (0C:A0) [16:42:56:781]: PROPERTY CHANGE: Adding 
WindowsFolder.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B
886_7BAABC047B61 property. Its value is 'C:\Windows\'.
Action ended 16:42:56: 
WindowsFolder.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B
886_7BAABC047B61. Return value 1.
MSI (c) (0C:A0) [16:42:56:781]: Doing action: PrepareDlg
MSI (c) (0C:A0) [16:42:56:781]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: PrepareDlg. 
Action start 16:42:56: PrepareDlg.
MSI (c) (0C:A0) [16:42:56:781]: Note: 1: 2235 2:  3: ExtendedType 4: 
SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM 
`CustomAction` WHERE `Action` = 'PrepareDlg' 
MSI (c) (0C:44) [16:42:56:781]: Note: 1: 2205 2:  3: Error 
MSI (c) (0C:44) [16:42:56:781]: Note: 1: 2228 2:  3: Error 4: SELECT 
`Message` FROM `Error` WHERE `Error` = 2898 
Info 2898.For WixUI_Font_Normal textstyle, the system created a 
'Tahoma' font, in 0 character set, of 13 pixels height.
MSI (c) (0C:44) [16:42:56:781]: Note: 1: 2205 2:  3: Error 
MSI (c) (0C:44) [16:42:56:781]: Note: 1: 2228 2:  3: Error 4: SELECT 
`Message` FROM `Error` WHERE `Error` = 2898 
Info 2898.For WixUI_Font_Bigger textstyle, the system created a 
'Tahoma' font, in 0 character set, of 19 pixels height.
Action 16:42:56: PrepareDlg. Dialog created
Action ended 16:42:56: PrepareDlg. Return value 1.
MSI (c) (0C:A0) [16:42:56:844]: Doing action: AppSearch
MSI (c) (0C:A0) [16:42:56:844]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: AppSearch. Searching for installed applications
Action start 16:42:56: AppSearch.
AppSearch: Property: WEBSERVERPICKER, Signature: webservertype
MSI (c) (0C:A0) [16:42:56:844]: Note: 1: 1402 2: 
HKEY_LOCAL_MACHINE\Software\PHP 3: 2 
AppSearch: Property: PHPINIEXISTS, Signature: CheckFile
MSI (c) (0C:A0) [16:42:56:844]: Note: 1: 1322 2:  
MSI (c) (0C:A0) [16:42:56:844]: Note: 1: 1322 2:  
AppSearch: Property: FASTCGI60MODULEINSTALLED, Signature: FcgiExtFile
AppSearch: Property: FASTCGI70MODULEINSTALLED, Signature: 
fastcgi70Registry
MSI (c) (0C:A0) [16:42:56:844]: PROPERTY CHANGE: Adding 
FASTCGI70MODULEINSTALLED property. Its value is '#1'.
AppSearch: Property: APACHEREGDIR, Signature: apacheRegistry
MSI (c) (0C:A0) [16:42:56:844]: Note: 1: 1402 2: 
HKEY_LOCAL_MACHINE\Software\PHP 3: 2 
Action ended 16:42:56: AppSearch. Return value 1.
MSI (c) (0C:A0) [16:42:56:844]: Doing action: LaunchConditions
MSI (c) (0C:A0) [16:42:56:844]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: LaunchConditions. Evaluating launch conditions
Action start 16:42:56: LaunchConditions.
Action ended 16:42:56: LaunchConditions. Return value 1.
MSI (c) (0C:A0) [16:42:56:844]: Doing action: FindRelatedProducts
MSI (c) (0C:A0) [16:42:56:844]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: FindRelatedProducts. Searching for related 
applications
Action start 16:42:56: FindRelatedProducts.
Action ended 16:42:56: FindRelatedProducts. Return value 1.
MSI (c) (0C:A0) [16:42:56:844]: Doing action: ValidateProductID
MSI (c) (0C:A0) [16:42:56:844]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: ValidateProductID. 
Action start 16:42:56: ValidateProductID.
Action ended 16:42:56: ValidateProductID. Return value 1.
MSI (c) (0C:A0) [16:42:56:844]: Doing action: CostInitialize
MSI (c) (0C:A0) [16:42:56:844]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: CostInitialize. Computing space requirements
Action start 16:42:56: CostInitialize.
MSI (c) (0C:A0) [16:42:56:859]: Machine policy value 
'MaxPatchCacheSize' is 10
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding ROOTDRIVE 
property. Its value is 'C:\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
CostingComplete property. Its value is '0'.
Action ended 16:42:56: CostInitialize. Return value 1.
MSI (c) (0C:A0) [16:42:56:859]: Skipping action: 
CheckFASTCGINOTINSTALLED (condition is false)
MSI (c) (0C:A0) [16:42:56:859]: Doing action: AssignAPACHEDIR
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: AssignAPACHEDIR. 
Action start 16:42:56: AssignAPACHEDIR.
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2235 2:  3: ExtendedType 4: 
SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM 
`CustomAction` WHERE `Action` = 'AssignAPACHEDIR' 
MSI (c) (0C:A0) [16:42:56:859]: WIN64DUALFOLDERS: 'C:\Program Files 
(x86)' will substitute 16 characters in 'C:\Program Files' folder 
path. (mask argument = 0, the folder pair's iSwapAttrib member = 0).
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding APACHEDIR 
property. Its value is 'C:\Program Files (x86)'.
Action ended 16:42:56: AssignAPACHEDIR. Return value 1.
MSI (c) (0C:A0) [16:42:56:859]: Skipping action: AssignAPACHEDIR2 
(condition is false)
MSI (c) (0C:A0) [16:42:56:859]: Doing action: CheckFASTCGIINSTALLED
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: CheckFASTCGIINSTALLED. 
Action start 16:42:56: CheckFASTCGIINSTALLED.
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2235 2:  3: ExtendedType 4: 
SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM 
`CustomAction` WHERE `Action` = 'CheckFASTCGIINSTALLED' 
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
FASTCGIINSTALLED property. Its value is '1'.
Action ended 16:42:56: CheckFASTCGIINSTALLED. Return value 1.
MSI (c) (0C:A0) [16:42:56:859]: Doing action: FileCost
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: FileCost. Computing space requirements
Action start 16:42:56: FileCost.
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2205 2:  3: Class 
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2205 2:  3: Extension 
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2205 2:  3: TypeLib 
Action ended 16:42:56: FileCost. Return value 1.
MSI (c) (0C:A0) [16:42:56:859]: Doing action: CostFinalize
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: CostFinalize. Computing space requirements
Action start 16:42:56: CostFinalize.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding OutOfDiskSpace 
property. Its value is '0'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
OutOfNoRbDiskSpace property. Its value is '0'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
PrimaryVolumeSpaceAvailable property. Its value is '0'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
PrimaryVolumeSpaceRequired property. Its value is '0'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
PrimaryVolumeSpaceRemaining property. Its value is '0'.
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2205 2:  3: Patch 
MSI (c) (0C:A0) [16:42:56:859]: Note: 1: 2205 2:  3: Condition 
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding TARGETDIR 
property. Its value is 'C:\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
WinSxsDirectory.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7
A_D7AD_3E2F_9ACB_44D8D43BD919 property. Its value is 
'C:\Windows\winsxs\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
WinSxsPolicies.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A
_D7AD_3E2F_9ACB_44D8D43BD919 property. Its value is 
'C:\Windows\winsxs\Policies\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
policydir.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_D7AD
_3E2F_9ACB_44D8D43BD919 property. Its value is 
'C:\Windows\winsxs\Policies\amd64_policy.9.0.Microsoft.VC90.CRT_1fc8b3
b9a1e18e3b_x-ww_16f3e195\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
payload_ul.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_D7A
D_3E2F_9ACB_44D8D43BD919 property. Its value is 
'C:\Windows\winsxs\amd64_policy.9.0.microsoft.vc90.crt_1fc8b3b9a1e18e3
b_9.0.21022.8_none_18f8a87fd1919cd9\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
WinSxsDirectory.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08
_B886_7BAABC047B61 property. Its value is 'C:\Windows\winsxs\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
policydir_ul.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B8
86_7BAABC047B61 property. Its value is 
'C:\Windows\winsxs\amd64_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_x-
ww_7701165b\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
WinSxsPolicies.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_
B886_7BAABC047B61 property. Its value is 
'C:\Windows\winsxs\Policies\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
policydir.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B886_
7BAABC047B61 property. Its value is 
'C:\Windows\winsxs\Policies\amd64_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_
x-ww_7701165b\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
WinSxsManifests.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08
_B886_7BAABC047B61 property. Its value is 
'C:\Windows\winsxs\Manifests\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
payload.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B886_7B
AABC047B61 property. Its value is 
'C:\Windows\winsxs\amd64_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.21022
.8_x-ww_0296e955\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
payload_ul.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B886
_7BAABC047B61 property. Its value is 
'C:\Windows\winsxs\amd64_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.21022
.8_none_750b37ff97f4f68b\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding ProgramMenuDir 
property. Its value is 'C:\ProgramData\Microsoft\Windows\Start 
Menu\Programs\PHP 5\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding INSTALLDIR 
property. Its value is 'C:\Program Files (x86)\PHP\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding 
extrasdirectory property. Its value is 'C:\Program Files 
(x86)\PHP\extras\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding extdirectory 
property. Its value is 'C:\Program Files (x86)\PHP\ext\'.
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding devdirectory 
property. Its value is 'C:\Program Files (x86)\PHP\dev\'.
MSI (c) (0C:A0) [16:42:56:859]: Target path resolution complete. 
Dumping Directory table...
MSI (c) (0C:A0) [16:42:56:859]: Note: target paths subject to change 
(via custom actions or browsing)
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: TARGETDIR	, 
Object: C:\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: WindowsFolder	
, Object: C:\Windows\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
WindowsFolder.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_
D7AD_3E2F_9ACB_44D8D43BD919	, Object: C:\Windows\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
WinSxsDirectory.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7
A_D7AD_3E2F_9ACB_44D8D43BD919	, Object: C:\Windows\winsxs\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
WinSxsPolicies.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A
_D7AD_3E2F_9ACB_44D8D43BD919	, Object: C:\Windows\winsxs\Policies\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
policydir.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_D7AD
_3E2F_9ACB_44D8D43BD919	, Object: 
C:\Windows\winsxs\Policies\amd64_policy.9.0.Microsoft.VC90.CRT_1fc8b3b
9a1e18e3b_x-ww_16f3e195\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
payload_ul.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_D7A
D_3E2F_9ACB_44D8D43BD919	, Object: 
C:\Windows\winsxs\amd64_policy.9.0.microsoft.vc90.crt_1fc8b3b9a1e18e3b
_9.0.21022.8_none_18f8a87fd1919cd9\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
WindowsFolder.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B
886_7BAABC047B61	, Object: C:\Windows\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
WinSxsDirectory.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08
_B886_7BAABC047B61	, Object: C:\Windows\winsxs\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
policydir_ul.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B8
86_7BAABC047B61	, Object: 
C:\Windows\winsxs\amd64_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_x-
ww_7701165b\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
WinSxsPolicies.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_
B886_7BAABC047B61	, Object: C:\Windows\winsxs\Policies\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
policydir.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B886_
7BAABC047B61	, Object: 
C:\Windows\winsxs\Policies\amd64_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_x
-ww_7701165b\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
WinSxsManifests.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08
_B886_7BAABC047B61	, Object: C:\Windows\winsxs\Manifests\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
payload.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B886_7B
AABC047B61	, Object: 
C:\Windows\winsxs\amd64_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.21022.
8_x-ww_0296e955\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: 
payload_ul.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B886
_7BAABC047B61	, Object: 
C:\Windows\winsxs\amd64_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.21022.
8_none_750b37ff97f4f68b\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: ProgramMenuFolder	
, Object: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: ProgramMenuDir	
, Object: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\PHP 5\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: ProgramFilesFolder	
, Object: C:\Program Files (x86)\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: INSTALLDIR	, 
Object: C:\Program Files (x86)\PHP\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: extrasdirectory	
, Object: C:\Program Files (x86)\PHP\extras\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: extdirectory	, 
Object: C:\Program Files (x86)\PHP\ext\
MSI (c) (0C:A0) [16:42:56:859]: Dir (target): Key: devdirectory	, 
Object: C:\Program Files (x86)\PHP\dev\
MSI (c) (0C:A0) [16:42:56:859]: PROPERTY CHANGE: Adding INSTALLLEVEL 
property. Its value is '1'.
MSI (c) (0C:A0) [16:42:56:875]: skipping installation of assembly 
component: {F24CABFE-ED58-3012-A491-F671A890E43B} since the assembly 
already exists
MSI (c) (0C:A0) [16:42:56:875]: skipping installation of assembly 
component: {6435B7C0-E0C8-3EA2-91AE-7640034EAFCE} since the assembly 
already exists
Action ended 16:42:56: CostFinalize. Return value 1.
MSI (c) (0C:A0) [16:42:56:875]: Doing action: MigrateFeatureStates
MSI (c) (0C:A0) [16:42:56:875]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: MigrateFeatureStates. Migrating feature states from 
related applications
Action start 16:42:56: MigrateFeatureStates.
Action ended 16:42:56: MigrateFeatureStates. Return value 0.
MSI (c) (0C:A0) [16:42:56:875]: Doing action: WelcomeDlg
MSI (c) (0C:A0) [16:42:56:875]: Note: 1: 2205 2:  3: ActionText 
Action 16:42:56: WelcomeDlg. 
Action start 16:42:56: WelcomeDlg.
MSI (c) (0C:A0) [16:42:56:875]: Note: 1: 2235 2:  3: ExtendedType 4: 
SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM 
`CustomAction` WHERE `Action` = 'WelcomeDlg' 
Action 16:42:56: WelcomeDlg. Dialog created
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: _RemoveFilePath 
MSI (c) (0C:04) [16:42:56:906]: PROPERTY CHANGE: Modifying 
CostingComplete property. Its current value is '0'. Its new value: 
'1'.
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: BindImage 
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: ProgId 
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: PublishComponent 
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: SelfReg 
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: Extension 
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: Font 
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: Class 
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: Icon 
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2205 2:  3: TypeLib 
MSI (c) (0C:04) [16:42:56:906]: Note: 1: 2727 2:  
MSI (c) (0C:44) [16:43:00:198]: Note: 1: 2205 2:  3: Error 
MSI (c) (0C:44) [16:43:00:198]: Note: 1: 2228 2:  3: Error 4: SELECT 
`Message` FROM `Error` WHERE `Error` = 2898 
Info 2898.For WixUI_Font_Title textstyle, the system created a 
'Tahoma' font, in 0 character set, of 14 pixels height.
Action 16:43:00: LicenseAgreementDlg. Dialog created
MSI (c) (0C:44) [16:43:01:368]: PROPERTY CHANGE: Adding 
LicenseAccepted property. Its value is '1'.
Action 16:43:02: InstallDirDlg. Dialog created
Action 16:43:06: WebServerDlg. Dialog created
MSI (c) (0C:44) [16:43:08:356]: PROPERTY CHANGE: Adding 
WEBSERVERPICKER property. Its value is 'iis4FastCGI'.
MSI (c) (0C:44) [16:43:13:489]: Note: 1: 2727 2:  
MSI (c) (0C:44) [16:43:13:489]: Note: 1: 2711 2: apache22 
MSI (c) (0C:44) [16:43:13:489]: Note: 1: 2205 2:  3: Error 
MSI (c) (0C:44) [16:43:13:489]: Note: 1: 2228 2:  3: Error 4: SELECT 
`Message` FROM `Error` WHERE `Error` = 2711 
DEBUG: Error 2711:  The specified Feature name ('apache22') not found 
in Feature Table.
The installer has encountered an unexpected error installing this 
package. This may indicate a problem with this package. The error code 
is 2711. The arguments are: apache22, , 
MSI (c) (0C:44) [16:43:15:174]: Note: 1: 2205 2:  3: Error 
MSI (c) (0C:44) [16:43:15:174]: Note: 1: 2228 2:  3: Error 4: SELECT 
`Message` FROM `Error` WHERE `Error` = 1709 
MSI (c) (0C:44) [16:43:15:174]: Product: PHP 5.3.0 -- The installer 
has encountered an unexpected error installing this package. This may 
indicate a problem with this package. The error code is 2711. The 
arguments are: apache22, , 

Action ended 16:43:15: WelcomeDlg. Return value 3.
MSI (c) (0C:A0) [16:43:15:189]: Doing action: FatalError
MSI (c) (0C:A0) [16:43:15:189]: Note: 1: 2205 2:  3: ActionText 
Action 16:43:15: FatalError. 
Action start 16:43:15: FatalError.
MSI (c) (0C:A0) [16:43:15:189]: Note: 1: 2235 2:  3: ExtendedType 4: 
SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM 
`CustomAction` WHERE `Action` = 'FatalError' 
Action 16:43:15: FatalError. Dialog created
Action ended 16:43:16: FatalError. Return value 2.
Action ended 16:43:16: INSTALL. Return value 3.
Property(C): Manufacturer = The PHP Group
Property(C): ProductCode = {C9E68706-081D-4302-8EED-309849864DA7}
Property(C): ProductLanguage = 1033
Property(C): ProductName = PHP 5.3.0
Property(C): ProductVersion = 5.3.0
Property(C): UpgradeCode = {91C7AD14-5A1B-4EB5-98B6-C0A9E4918CA9}
Property(C): DiskPrompt = PHP Installer
Property(C): ALLUSERS = 1
Property(C): WIXUI_INSTALLDIR = INSTALLDIR
Property(C): INSTALLDIR = C:\Program Files (x86)\PHP\
Property(C): DefaultUIFont = WixUI_Font_Normal
Property(C): WixUI_Mode = FeatureTree
Property(C): ErrorDialog = ErrorDlg
Property(C): WixUIRMOption = UseRM
Property(C): WixUI_WelcomeDlg_Next = LicenseAgreementDlg
Property(C): WixUI_LicenseAgreementDlg_Back = WelcomeDlg
Property(C): WixUI_LicenseAgreementDlg_Next = InstallDirDlg
Property(C): WixUI_InstallDirDlg_Back = LicenseAgreementDlg
Property(C): WixUI_InstallDirDlg_Next = WebServerDlg
Property(C): WixUI_InstallDirDlg_Browse = BrowseDlg
Property(C): WixUI_WebServerDlg_Back = InstallDirDlg
Property(C): WixUI_WebServerDlg_BackChange = MaintenanceTypeDlg
Property(C): WixUI_WebServerDlg_Next = CustomizeDlg
Property(C): WixUI_WebServerDlg_NextApache = ApacheDlg
Property(C): WixUI_ApacheDlg_Back = WebServerDlg
Property(C): WixUI_ApacheDlg_Next = CustomizeDlg
Property(C): WixUI_ApacheDlg_Browse = BrowseApacheDlg
Property(C): WixUI_CustomizeDlg_BackChange = WebServerDlg
Property(C): WixUI_CustomizeDlg_BackCustom = SetupTypeDlg
Property(C): WixUI_CustomizeDlg_BackFeatureTree = WebServerDlg
Property(C): WixUI_CustomizeDlg_Next = VerifyReadyDlg
Property(C): WixUI_VerifyReadyDlg_BackCustom = CustomizeDlg
Property(C): WixUI_VerifyReadyDlg_BackChange = CustomizeDlg
Property(C): WixUI_VerifyReadyDlg_BackRepair = MaintenanceTypeDlg
Property(C): WixUI_VerifyReadyDlg_BackRemove = MaintenanceTypeDlg
Property(C): WixUI_VerifyReadyDlg_BackTypical = SetupTypeDlg
Property(C): WixUI_VerifyReadyDlg_BackFeatureTree = CustomizeDlg
Property(C): WixUI_VerifyReadyDlg_BackComplete = SetupTypeDlg
Property(C): WixUI_MaintenanceWelcomeDlg_Next = MaintenanceTypeDlg
Property(C): WixUI_MaintenanceTypeDlg_Change = WebServerDlg
Property(C): WixUI_MaintenanceTypeDlg_Repair = VerifyReadyDlg
Property(C): WixUI_MaintenanceTypeDlg_Remove = VerifyReadyDlg
Property(C): WixUI_MaintenanceTypeDlg_Back = MaintenanceWelcomeDlg
Property(C): SecureCustomProperties = OLDVERSION
Property(C): LicenseAccepted = 1
Property(C): WEBSERVERPICKER = iis4FastCGI
Property(C): ProgramMenuDir = C:\ProgramData\Microsoft\Windows\Start 
Menu\Programs\PHP 5\
Property(C): FASTCGI70MODULEINSTALLED = #1
Property(C): devdirectory = C:\Program Files (x86)\PHP\dev\
Property(C): ProgramFilesFolder = C:\Program Files (x86)\
Property(C): TARGETDIR = C:\
Property(C): ProgramMenuFolder = 
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\
Property(C): SourceDir = C:\Users\Administrator\Desktop\PHP\
Property(C): extdirectory = C:\Program Files (x86)\PHP\ext\
Property(C): extrasdirectory = C:\Program Files (x86)\PHP\extras\
Property(C): FASTCGIINSTALLED = 1
Property(C): APACHEDIR = C:\Program Files (x86)
Property(C): 
WinSxsDirectory.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08
_B886_7BAABC047B61 = C:\Windows\winsxs\
Property(C): 
payload_ul.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B886
_7BAABC047B61 = 
C:\Windows\winsxs\amd64_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.21022.
8_none_750b37ff97f4f68b\
Property(C): 
payload.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B886_7B
AABC047B61 = 
C:\Windows\winsxs\amd64_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.21022.
8_x-ww_0296e955\
Property(C): 
WinSxsManifests.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08
_B886_7BAABC047B61 = C:\Windows\winsxs\Manifests\
Property(C): 
WindowsFolder.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B
886_7BAABC047B61 = C:\Windows\
Property(C): 
WinSxsPolicies.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_
B886_7BAABC047B61 = C:\Windows\winsxs\Policies\
Property(C): 
policydir.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B886_
7BAABC047B61 = 
C:\Windows\winsxs\Policies\amd64_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_x
-ww_7701165b\
Property(C): 
policydir_ul.21022.08.Microsoft_VC90_CRT_x64.RTM.50FC30FE_9758_3B08_B8
86_7BAABC047B61 = 
C:\Windows\winsxs\amd64_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_x-
ww_7701165b\
Property(C): 
Dummy_Microsoft_VC90_CRT_x64.50FC30FE_9758_3B08_B886_7BAABC047B61 = 1
Property(C): 
WinSxsDirectory.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7
A_D7AD_3E2F_9ACB_44D8D43BD919 = C:\Windows\winsxs\
Property(C): 
payload_ul.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_D7A
D_3E2F_9ACB_44D8D43BD919 = 
C:\Windows\winsxs\amd64_policy.9.0.microsoft.vc90.crt_1fc8b3b9a1e18e3b
_9.0.21022.8_none_18f8a87fd1919cd9\
Property(C): 
WinSxsPolicies.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A
_D7AD_3E2F_9ACB_44D8D43BD919 = C:\Windows\winsxs\Policies\
Property(C): 
policydir.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_D7AD
_3E2F_9ACB_44D8D43BD919 = 
C:\Windows\winsxs\Policies\amd64_policy.9.0.Microsoft.VC90.CRT_1fc8b3b
9a1e18e3b_x-ww_16f3e195\
Property(C): 
WindowsFolder.21022.08.policy_9_0_Microsoft_VC90_CRT_x64.RTM.D8FD5D7A_
D7AD_3E2F_9ACB_44D8D43BD919 = C:\Windows\
Property(C): 
Dummy_policy_9_0_Microsoft_VC90_CRT_x64.D8FD5D7A_D7AD_3E2F_9ACB_44D8D4
3BD919 = 1
Property(C): MsiLogFileLocation = 
C:\Users\Administrator\Desktop\PHP\error.log
Property(C): PackageCode = {DC36AD73-169E-41EC-8C45-016D75DA70E4}
Property(C): ProductState = -1
Property(C): PackagecodeChanging = 1
Property(C): CURRENTDIRECTORY = C:\Users\Administrator\Desktop\PHP
Property(C): CLIENTUILEVEL = 0
Property(C): CLIENTPROCESSID = 2572
Property(C): VersionDatabase = 100
Property(C): MsiSystemRebootPending = 1
Property(C): VersionMsi = 5.00
Property(C): VersionNT = 601
Property(C): VersionNT64 = 601
Property(C): WindowsBuild = 7600
Property(C): ServicePackLevel = 0
Property(C): ServicePackLevelMinor = 0
Property(C): MsiNTProductType = 2
Property(C): MsiNTSuiteEnterprise = 1
Property(C): WindowsFolder = C:\Windows\
Property(C): WindowsVolume = C:\
Property(C): System64Folder = C:\Windows\system32\
Property(C): SystemFolder = C:\Windows\SysWOW64\
Property(C): RemoteAdminTS = 1
Property(C): TempFolder = C:\Users\ADMINI~1\AppData\Local\Temp\1\
Property(C): CommonFilesFolder = C:\Program Files (x86)\Common Files\
Property(C): ProgramFiles64Folder = C:\Program Files\
Property(C): CommonFiles64Folder = C:\Program Files\Common Files\
Property(C): AppDataFolder = C:\Users\Administrator\AppData\Roaming\
Property(C): FavoritesFolder = C:\Users\Administrator\Favorites\
Property(C): NetHoodFolder = 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Network 
Shortcuts\
Property(C): PersonalFolder = C:\Users\Administrator\Documents\
Property(C): PrintHoodFolder = 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Printer 
Shortcuts\
Property(C): RecentFolder = 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Recent\
Property(C): SendToFolder = 
C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\SendTo\
Property(C): TemplateFolder = 
C:\ProgramData\Microsoft\Windows\Templates\
Property(C): CommonAppDataFolder = C:\ProgramData\
Property(C): LocalAppDataFolder = 
C:\Users\Administrator\AppData\Local\
Property(C): MyPicturesFolder = C:\Users\Administrator\Pictures\
Property(C): AdminToolsFolder = C:\ProgramData\Microsoft\Windows\Start 
Menu\Programs\Administrative Tools\
Property(C): StartupFolder = C:\ProgramData\Microsoft\Windows\Start 
Menu\Programs\Startup\
Property(C): StartMenuFolder = C:\ProgramData\Microsoft\Windows\Start 
Menu\
Property(C): DesktopFolder = C:\Users\Public\Desktop\
Property(C): FontsFolder = C:\Windows\Fonts\
Property(C): GPTSupport = 1
Property(C): OLEAdvtSupport = 1
Property(C): ShellAdvtSupport = 1
Property(C): MsiAMD64 = 6
Property(C): Msix64 = 6
Property(C): Intel = 6
Property(C): PhysicalMemory = 4095
Property(C): VirtualMemory = 5426
Property(C): AdminUser = 1
Property(C): MsiTrueAdminUser = 1
Property(C): LogonUser = Administrator
Property(C): UserSID = S-1-5-21-120647167-3249740214-1701920253-500
Property(C): UserLanguageID = 1031
Property(C): ComputerName = MEISTER
Property(C): SystemLanguageID = 1031
Property(C): ScreenX = 1280
Property(C): ScreenY = 1024
Property(C): CaptionHeight = 22
Property(C): BorderTop = 1
Property(C): BorderSide = 1
Property(C): TextHeight = 16
Property(C): TextInternalLeading = 3
Property(C): ColorBits = 32
Property(C): TTCSupport = 1
Property(C): Time = 16:43:16
Property(C): Date = 01.01.2010
Property(C): MsiNetAssemblySupport = 2.0.50727.4927
Property(C): MsiWin32AssemblySupport = 6.1.7600.16385
Property(C): RedirectedDllSupport = 2
Property(C): MsiRunningElevated = 1
Property(C): Privileged = 1
Property(C): USERNAME = Windows-Benutzer
Property(C): DATABASE = C:\Users\Administrator\Desktop\PHP\php-5.3-
nts-win32-VC9-x64-latest.msi
Property(C): OriginalDatabase = 
C:\Users\Administrator\Desktop\PHP\php-5.3-nts-win32-VC9-x64-
latest.msi
Property(C): SOURCEDIR = C:\Users\Administrator\Desktop\PHP\
Property(C): VersionHandler = 5.00
Property(C): UILevel = 5
Property(C): ACTION = INSTALL
Property(C): EXECUTEACTION = INSTALL
Property(C): ROOTDRIVE = C:\
Property(C): CostingComplete = 1
Property(C): OutOfDiskSpace = 0
Property(C): OutOfNoRbDiskSpace = 0
Property(C): PrimaryVolumeSpaceAvailable = 0
Property(C): PrimaryVolumeSpaceRequired = 0
Property(C): PrimaryVolumeSpaceRemaining = 0
Property(C): INSTALLLEVEL = 1
=== Logging stopped: 01.01.2010  16:43:16 ===
MSI (c) (0C:A0) [16:43:16:609]: Note: 1: 1708 
MSI (c) (0C:A0) [16:43:16:609]: Note: 1: 2205 2:  3: Error 
MSI (c) (0C:A0) [16:43:16:609]: Note: 1: 2228 2:  3: Error 4: SELECT 
`Message` FROM `Error` WHERE `Error` = 1708 
MSI (c) (0C:A0) [16:43:16:609]: Note: 1: 2205 2:  3: Error 
MSI (c) (0C:A0) [16:43:16:609]: Note: 1: 2228 2:  3: Error 4: SELECT 
`Message` FROM `Error` WHERE `Error` = 1709 
MSI (c) (0C:A0) [16:43:16:609]: Product: PHP 5.3.0 -- Installation 
failed.

MSI (c) (0C:A0) [16:43:16:609]: Windows Installer installed the 
product. Product Name: PHP 5.3.0. Product Version: 5.3.0. Product 
Language: 1033. Manufacturer: The PHP Group. Installation success or 
error status: 1603.

MSI (c) (0C:A0) [16:43:16:609]: Grabbed execution mutex.
MSI (c) (0C:A0) [16:43:16:609]: Cleaning up uninstalled install 
packages, if any exist
MSI (c) (0C:A0) [16:43:16:609]: MainEngineThread is returning 1603
=== Verbose logging stopped: 01.01.2010  16:43:16 ===
 [2010-03-25 19:05 UTC] jmertic@php.net
-Status: Assigned +Status: Closed
 [2010-03-25 19:05 UTC] jmertic@php.net
Closing since 6.0 as we knew it is gone and the snaps are down.
 [2011-07-27 00:43 UTC] edub at scripturechannel dot org
I had this same problem..   I found that it was because I was installing the NON 
thread safe version of PHP...  when I downloaded the Thread Safe Version it worked 
fine.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 13:05:44 2022 UTC