php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48605 bugtracker parses urls incorrectly
Submitted: 2009-06-19 12:50 UTC Modified: 2010-06-18 22:41 UTC
From: theultramage at gmail dot com Assigned: jani (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: theultramage at gmail dot com
New email:
PHP Version: OS:

 

 [2009-06-19 12:50 UTC] theultramage at gmail dot com
Description:
------------
In two bugreports of mine, I referenced revision deltas on cvs.php.net. In both cases, I noticed that the resulting bugreport page only displays part of the url as link, cutting it off and making it invalid.

It seems the issue is with how the comment text is word-wrapped into the <pre> block. In the two cases I know of, the url got cut off at a dot (.) and ampersand(&). This issue prevents people who don't notice the problem from accessing the pages.



Reproduce code:
---------------
Visit
http://bugs.php.net/bug.php?id=48224
http://bugs.php.net/bug.php?id=48601
and check out the urls.

Expected result:
----------------
http://cvs.php.net/viewvc.cgi/php-src/ext/standard/array.c?r1=1.79&r2=1.80&
http://cvs.php.net/viewvc.cgi/php-src/ext/simplexml/simplexml.c?r1=1.78&r2=1.79

Actual result:
--------------
http://cvs.php.net/viewvc.cgi/php-src/ext/standard/array.c?r1=1.79&r2=1.
80&
http://cvs.php.net/viewvc.cgi/php-src/ext/simplexml/simplexml.c?r1=1.78
&r2=1.79

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-02 02:11 UTC] kalle@php.net
-Status: Open +Status: Verified
 [2010-03-02 02:11 UTC] kalle@php.net
This have partially been fixed by the new bug tracker, however it still uses a static sized <pre> so the bug is still there for really long links but should indeed be fixed
 [2010-03-09 19:35 UTC] jani@php.net
-Status: Verified +Status: Assigned -Assigned To: +Assigned To: jani
 [2010-06-18 22:41 UTC] jani@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 07:01:28 2024 UTC