php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48554 php mail function connectivity problem
Submitted: 2009-06-15 09:52 UTC Modified: 2009-07-01 05:34 UTC
From: lakshmi at nace dot co dot in Assigned:
Status: Not a bug Package: Mail related
PHP Version: 5.2.10RC2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lakshmi at nace dot co dot in
New email:
PHP Version: OS:

 

 [2009-06-15 09:52 UTC] lakshmi at nace dot co dot in
Description:
------------
In LINUX (throught proxy connection) I cannot able to send the mail function, mail function is working properly it will shows an message "msg sent successfully" but it is not reaching the destination email id.

In LINUX (throught direct internet connection) mail function is also working properly and also the mail is reaching the destination email id perfectly.

how can i rectify this problem


Reproduce code:
---------------
---
From manual page: book.mail
---
<?php

$Name = "Da Duder"; //senders name
$email = "email@adress.com"; //senders e-mail adress
$recipient = "PersonWhoGetsIt@emailadress.com"; //recipient
$mail_body = "The text for the mail..."; //mail body
$subject = "Subject for reviever"; //subject
$header = "From: ". $Name . " <" . $email . ">\r\n"; //optional headerfields
if(mail($recipient, $subject, $mail_body, $header)) //mail command :)
echo "mail sent";
else
echo "mail failed to sent
?>

Expected result:
----------------
this function executes in direct internet connection, but it has to work when i am using proxy connection too.

Actual result:
--------------
it has to display the output

mail sent

and it has to reach to the destination(receiptent) email id

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-15 11:07 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2009-06-24 11:27 UTC] lakshmi at nace dot co dot in
cannot send email using mail() through proxy connection(static ip address) if I use direct connection (dynamic ip address) can able to send and receive the mail 




can anyone help me out to sort this problem
 [2009-07-01 05:34 UTC] lakshmi at nace dot co dot in
cannot send email using mail() through proxy connection(static ip
address) if I use direct connection (dynamic ip address) can able to
send and receive the mail 

can anyone help me out to sort this problem
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Sep 24 23:05:52 2022 UTC