php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48494 Syntex Error
Submitted: 2009-06-08 09:03 UTC Modified: 2009-06-28 18:20 UTC
From: walidantar at live dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.9 OS: Windows 7 x86, Windows xp x86
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: walidantar at live dot com
New email:
PHP Version: OS:

 

 [2009-06-08 09:03 UTC] walidantar at live dot com
Description:
------------
When I run Test Configuration "httpd.exe" it gives a message that says syntex error at line 490 "Only first PHPINIDIR directive honored per configuration tree - subsequent ones ignored"

Reproduce code:
---------------
#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
ScriptAlias /php/ "E:/Program Files/PHP/"
Action application/x-httpd-php "E:/Program Files/PHP/php-cgi.exe"
PHPIniDir "E:/Program Files/PHP/" //only this directive is required
LoadModule php5_module "E:/Program Files/PHP/php5apache2_2.dll"
#PHPIniDir "E:/Program Files/PHP/" //must be omitted
LoadModule php5_module "E:/Program Files/PHP/php5apache2.dll"
#PHPIniDir "E:/Program Files/PHP/" //must be omitted
LoadModule php5_module "E:/Program Files/PHP/php5apache.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-28 18:20 UTC] jmertic@php.net
Sounds like you tried to install with all options available; this isn't supported, since it would install all SAPIs and all extensions. You should instead stick with the default install and add to it the extensions/features needed.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 24 13:03:50 2022 UTC