php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48490 php configure --with-mysql failed with macports
Submitted: 2009-06-07 13:42 UTC Modified: 2009-06-08 19:11 UTC
From: senz at senz dot su Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.9 OS: Darwin 9.7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: senz at senz dot su
New email:
PHP Version: OS:

 

 [2009-06-07 13:42 UTC] senz at senz dot su
Description:
------------
php 5.2.9 configure script failed with option --with-mysql=shared,/opt/local

uname -rs
Darwin 9.7.0

The following ports are currently installed:
  mysql5-devel @5.1.34_0 (active)

Reproduce code:
---------------
./configure \
--with-mysql=shared,/opt/local

Actual result:
--------------
checking for MySQL support... yes, shared
checking for specified location of the MySQL UNIX socket... no
checking for MySQL UNIX socket location... no
configure: error: Cannot find MySQL header files under /opt/local.
Note that the MySQL client library is not bundled anymore!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-07 13:46 UTC] senz at senz dot su
This post helps to resolve the problem: http://lists.macosforge.org/pipermail/macports-users/2007-December/007567.html

It seems that macports change paths for mysql installation.
 [2009-06-08 19:11 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 01:05:44 2022 UTC