php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #48485 Error in documentation and upgrade guide
Submitted: 2009-06-06 11:43 UTC Modified: 2009-06-21 18:35 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: a dot schilder at gmx dot net Assigned:
Status: Closed Package: Documentation problem
PHP Version: 5.3 OS: irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: a dot schilder at gmx dot net
New email:
PHP Version: OS:

 

 [2009-06-06 11:43 UTC] a dot schilder at gmx dot net
Description:
------------
I had problems with the session and found out, that in PHP 5.3 the default value for "session.use_only_cookies" has changed from "0" to "1" although the documentation says: "This setting was added in PHP 4.3.0. Defaults to 1 (enabled) since PHP 6.0."


So until PHP 5.2.x (including 5.2.10) the default value is "0" (as also mentioned in the php.ini for these versions), from PHP 5.3 the default is "1". 

This means:

- The mentioned default value in the table at manual page "session.configuration.php" is wrong, because that's not valid for current stable versions.

- The sentence mentioned above is also wrong - should be "PHP 5.3" instead of "PHP 6.0".

- This change is missing in the PHP 5.3 upgrade guide at http://wiki.php.net/doc/scratchpad/upgrade/53

Reproduce code:
---------------
not needed

Expected result:
----------------
not needed

Actual result:
--------------
not needed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-06 11:46 UTC] a dot schilder at gmx dot net
Version added
 [2009-06-08 14:01 UTC] kalle@php.net
Thats not the upgrade guide, we don't have an upgrade guide for PHP 5.3 yet, this is however the scratchpad for our upgrade guide, things that needs to be documented in the manual, some of it may already have been documented and others have not yet been ;)
 [2009-06-21 18:35 UTC] bjori@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 10:01:28 2024 UTC