php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48479 enable-zend-multibyte breaks compilation
Submitted: 2009-06-05 11:30 UTC Modified: 2010-12-20 12:43 UTC
From: gabriel at e-radical dot ro Assigned:
Status: Not a bug Package: mbstring related
PHP Version: 5.3.0RC2 OS: Centos 5.3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: gabriel at e-radical dot ro
New email:
PHP Version: OS:

 

 [2009-06-05 11:30 UTC] gabriel at e-radical dot ro
Description:
------------
If you use --enable-zend-multibyte the compiles exists.

Reproduce code:
---------------
./configure --cache-file=../php-5.3.0RC2.cache --with-apxs2           \
--with-gd --enable-gd-native-ttf --with-gettext --enable-ftp          \
--enable-soap --with-curl --with-zlib --enable-mod-charset            \
--disable-short-tags --with-openssl --with-kerberos --with-pcre-regex \
--without-sqlite3 --enable-bcmath --with-bz2 --enable-calendar        \
--enable-ctype --with-curl --disable-dba --enable-dom --enable-exif   \
--enable-fileinfo --enable-filter --enable-ftp --enable-gd-jis-conv   \
--with-gmp --with-mhash --enable-hash --with-iconv --with-imap        \
--with-imap-ssl --enable-intl --enable-json --with-ldap               \
--with-ldap-sasl --enable-mbstring --enable-mbregex                   \
--enable-mbregex-backtrack --with-libmbfl --with-onig --with-mcrypt   \
--with-mysql=mysqlnd --with-mysqli=mysqlnd --enable-pcntl             \
--enable-pdo --with-pdo-mysql=mysqlnd --without-pdo-sqlite            \
--enable-phar --enable-posix --without-libedit --without-readline     \
--without-recode --enable-session --without-mm --enable-shmop         \
--enable-simplexml --with-snmp --with-openssl-dir --enable-soap       \
--enable-ucd-snmp-hack --enable-sockets --without-sqlite              \
--enable-sysvmsg --enable-sysvsem --enable-sysvshm --with-tidy        \
--enable-wddx --enable-xml --enable-xmlreader --with-xmlrpc           \
--enable-xmlwriter --with-xsl --enable-zip --with-pcre-dir            \
--enable-mysqlnd-threading --with-pear --enable-zend-multibyte

Actual result:
--------------
/bin/sh /root/installed/php-5.3.0RC2/libtool --silent --preserve-dup-deps --mode=compile /root/installed/php-5.3.0RC2/meta_ccld  -Iext/mbstring/ -I/root/installed/php-5.3.0RC2/ext/mbstring/ -DPHP_ATOM_INC -I/root/installed/php-5.3.0RC2/include -I/root/installed/php-5.3.0RC2/main -I/root/installed/php-5.3.0RC2 -I/root/installed/php-5.3.0RC2/ext/ereg/regex -I/usr/include/libxml2 -I/usr/kerberos/include -I/root/installed/php-5.3.0RC2/ext/date/lib -I/usr/include/imap -I/root/installed/php-5.3.0RC2/ext/mbstring/oniguruma -I/root/installed/php-5.3.0RC2/ext/mbstring/libmbfl -I/root/installed/php-5.3.0RC2/ext/mbstring/libmbfl/mbfl -I/root/installed/php-5.3.0RC2/TSRM -I/root/installed/php-5.3.0RC2/Zend    -I/usr/include -g -O2 -fvisibility=hidden -DZTS   -c /root/installed/php-5.3.0RC2/ext/mbstring/mbstring.c -o ext/mbstring/mbstring.lo 
/root/installed/php-5.3.0RC2/ext/mbstring/mbstring.c:4726: error: static declaration of 'php_mb_set_zend_encoding' follows non-static declaration
/root/installed/php-5.3.0RC2/ext/mbstring/mbstring.c:1451: error: previous implicit declaration of 'php_mb_set_zend_encoding' was here
/root/installed/php-5.3.0RC2/ext/mbstring/mbstring.c: In function 'php_mb_set_zend_encoding':
/root/installed/php-5.3.0RC2/ext/mbstring/mbstring.c:4757: error: 'php_mb_encoding_detector' undeclared (first use in this function)
/root/installed/php-5.3.0RC2/ext/mbstring/mbstring.c:4757: error: (Each undeclared identifier is reported only once
/root/installed/php-5.3.0RC2/ext/mbstring/mbstring.c:4757: error: for each function it appears in.)
/root/installed/php-5.3.0RC2/ext/mbstring/mbstring.c:4758: error: 'php_mb_encoding_converter' undeclared (first use in this function)
/root/installed/php-5.3.0RC2/ext/mbstring/mbstring.c:4759: error: 'php_mb_oddlen' undeclared (first use in this function)
make: *** [ext/mbstring/mbstring.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-09 02:24 UTC] scottmac@php.net
Duplicate of bug #48200
 [2010-12-20 12:43 UTC] jani@php.net
-Package: Tidy +Package: mbstring related
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 26 10:05:45 2022 UTC