php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48463 Strange unicode output for internal "main" constants
Submitted: 2009-06-03 17:17 UTC Modified: 2015-02-18 07:49 UTC
From: kalle@php.net Assigned: andrei (profile)
Status: Wont fix Package: Unicode Engine related
PHP Version: 6CVS-2009-06-03 (CVS) OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: kalle@php.net
New email:
PHP Version: OS:

 

 [2009-06-03 17:17 UTC] kalle@php.net
Description:
------------
Internal "main" registered constants, (constants with module_number = 0, Core) have weird behaviour when they are fetched from get_defined_constants(), this could suggest that its either get_defined_constants() or something generally wrong with these constants and Unicode. See the actual result output for the unicode garbage thats returned.

Reproduce code:
---------------
print_r(get_defined_constants());

Expected result:
----------------
See Actual result, output without unicode garbage

Actual result:
--------------
http://pastie.org/499080

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-18 07:49 UTC] krakjoe@php.net
-Status: Assigned +Status: Wont fix
 [2015-02-18 07:49 UTC] krakjoe@php.net
Since the 6 branch has been abandoned, I'm marking this as won't fix ...

Just trying to do housework on bugs.php.net, this report can still be found for reference.

Sorry about the wait, and disappointment.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 21:04:10 2022 UTC