php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4846 Seg fault or write error if no vars registered
Submitted: 2000-06-06 23:35 UTC Modified: 2000-08-06 00:42 UTC
From: serge at globalbeach dot com Assigned:
Status: Closed Package: Session related
PHP Version: 4.0.0 Release OS: RH Linux 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: serge at globalbeach dot com
New email:
PHP Version: OS:

 

 [2000-06-06 23:35 UTC] serge at globalbeach dot com
Hello,

Strange behavior with sessions if you do a session_start() at two different instances without actually registering any variables then:

if you use the internal session handler files or mm you get
some sort of php write error when you run session_start() for the second time.

if you use an extrernal session handler you get a segmentation fault.

temp. fix is to regsiter at least one variable when you do the first session_start()

Serge

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-26 07:09 UTC] zak@php.net
Will test asap with new release
 [2000-08-06 00:42 UTC] zak@php.net
Could not reproduce. Please try a recent release of PHP.  If the error re-occurs, please submit a new bug report.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 10:03:45 2023 UTC