php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48426 PDO::exec() never modifies
Submitted: 2009-05-29 06:20 UTC Modified: 2009-05-29 07:02 UTC
From: jengert at gmail dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 5.2.9 OS: OS X 10.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jengert at gmail dot com
New email:
PHP Version: OS:

 

 [2009-05-29 06:20 UTC] jengert at gmail dot com
Description:
------------
my table looks like this

CREATE TABLE `volunteer` (
  `volunteer_id` integer PRIMARY KEY,
  `origin_id` int(10) NOT NULL,
  `name` varchar(200) NOT NULL,
  UNIQUE (`name`)
);

Works via command line, not through apache (with and w/o entropy)

Reproduce code:
---------------
$db =  new PDO('sqlite:mealdata.sqlite');
$querystring = "INSERT INTO `volunteer` (`origin_id` , `name`) VALUES (3, 'my name')";
$query = $db->exec($querystring);
echo $query;

Expected result:
----------------
1

Actual result:
--------------
0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-29 07:02 UTC] jengert at gmail dot com
permissions set wrong on file
I'm sorry for submitting this!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 10:03:34 2021 UTC