php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4840 session_register fails to save variable value if register_globals = Off
Submitted: 2000-06-06 16:51 UTC Modified: 2000-06-13 23:32 UTC
From: serges at globalbeach dot com Assigned:
Status: Closed Package: Session related
PHP Version: 4.0.0 Release OS: RH Linux 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: serges at globalbeach dot com
New email:
PHP Version: OS:

 

 [2000-06-06 16:51 UTC] serges at globalbeach dot com
If I set register_globals = Off then no then no value is stored for the
variable that I regsitered via session_register()
When I look at the session file, I can see the variable name but there is no value. Changing register_globals = On in php.ini fixes this.

This might be by design but it is not documented anywhere I could find
it, so I wasted some extra time on this.....

Serge

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-06-13 23:32 UTC] andrei at cvs dot php dot net
With register_globals off, the variables to be stored need
to be in $HTTP_SESSION_VARS.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Jan 31 19:05:53 2023 UTC