php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48325 IIS7 isapi - cannot enable curl extension
Submitted: 2009-05-19 01:52 UTC Modified: 2012-05-01 20:15 UTC
From: jpgorton at gmail dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.9 OS: windows server 2008 64bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jpgorton at gmail dot com
New email:
PHP Version: OS:

 

 [2009-05-19 01:52 UTC] jpgorton at gmail dot com
Description:
------------
I have windows server 2008 64bit.. with IIS7. If I run PHP via 
FastCGI the curl extension will load, but if I run PHP via isapi the 
curl extension will not load and does not appear in phpinfo(). Other 
extensions (ie sqlite) will load both ways.





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-24 22:27 UTC] jpgorton at gmail dot com
I just found this...

http://www.webmasterworld.com/php/3412713.htm

it fixed my problem..
I had to copy libeay32.dll and ssleay32.dll from the PHP folder into 
c:/windows/syswow64 folder. Then recycled the iis application pool 
and it works. I guess it wasn't a php problem, but more of a windows 
problem? perhaps I'll stick this in as a comment on the curl 
documentation page. thanks guys and gals.
 [2012-05-01 18:23 UTC] cristianfloyd at gmail dot com
Hi, i solved problem just said jpgorton.
copying  libeay32.dll and ssleay32.dll to "windows\syswow64" folder.
 [2012-05-01 20:15 UTC] pajoye@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 20:03:45 2023 UTC