php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #48241 what does "->" mean?
Submitted: 2009-05-12 06:03 UTC Modified: 2009-05-13 07:15 UTC
From: hj at BridgeportContractor dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hj at BridgeportContractor dot com
New email:
PHP Version: OS:

 

 [2009-05-12 06:03 UTC] hj at BridgeportContractor dot com
Description:
------------
Only reference I can find in manual for "->" construct is under objects, but even there I can't find what it means.  It's used all over, but ??  I've searched index and search too and can't find it listed.  -- Thanks!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-12 06:10 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 [2009-05-13 03:20 UTC] hj at BridgeportContractor dot com
Please, not so fast...



In the PHP manual under:

  "Appendices:" 
    "How to help improve the documentation:" 
      "How to help improve the documentation:"

It says:

    "If an error is found in this manual, in any language, please report them using the bug system at ? http://bugs.php.net/."


Also the "bug report" I submitted reads:

    "Bug Type:         Documentation problem"


Is it not a problem to you that a major construct of the language (i.e. -> ) is not doccumented AT ALL in the manual?
 [2009-05-13 03:22 UTC] hj at BridgeportContractor dot com
I meant...



...Appendices:" 
    "About the manual:"    <---correction
      "How to help ...
 [2009-05-13 07:11 UTC] bjori@php.net
You are right, -> is never explicitly documented, that doesn't seem to have affected anyone in the past though.

As it isn't documented by now, I doubt anyone ever will - if you have specific suggestions however we could probably incorporate it.


 [2009-05-13 07:15 UTC] derick@php.net
There is a whole section in the manual about objects and classes:

http://no.php.net/manual/en/language.oop5.php
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jun 22 15:01:24 2021 UTC