php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #48226 Support for atomic ldap modify operations
Submitted: 2009-05-10 19:33 UTC Modified: 2015-06-10 11:17 UTC
Votes:12
Avg. Score:4.8 ± 0.6
Reproduced:12 of 12 (100.0%)
Same Version:9 (75.0%)
Same OS:9 (75.0%)
From: bugs dot php at jensthebrain dot de Assigned: mcmic (profile)
Status: Closed Package: LDAP related
PHP Version: 5.2.9 OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugs dot php at jensthebrain dot de
New email:
PHP Version: OS:

 

 [2009-05-10 19:33 UTC] bugs dot php at jensthebrain dot de
Description:
------------
It's a common scenario that you need to increase a counter atomically. E.g. the UidNumber-Counter for a sambaUnixIdPool.

With perl you need just a few lines:

my $umsg = $ld->modify($dn,
delete => { 'uidNumber' => $currentvalue },
add => { 'uidNumber' => $nextvalue});

But this seems not to be possible with PHP because you need two functions calls (ldap_delete, ldap_add) or support for defining operations in ldap_modify.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-01-02 02:31 UTC] jani@php.net
-Package: Feature/Change Request +Package: LDAP related
 [2015-06-10 11:17 UTC] mcmic@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: mcmic
 [2015-06-10 11:17 UTC] mcmic@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 09:01:27 2024 UTC