php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #4822 Uploading in safe mode
Submitted: 2000-06-05 15:53 UTC Modified: 2000-11-21 03:58 UTC
From: stano at upjs dot sk Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0.0 Release OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stano at upjs dot sk
New email:
PHP Version: OS:

 

 [2000-06-05 15:53 UTC] stano at upjs dot sk
I have two ways for problem in uploading files in safe mode.

If I upload file to www server, php save them to file like /tmp/php.....
owner of this file is: nobody, or web user

First way:
in php3, new rule in php3.ini ( or php4.ini )
safe_mode_upload_dir
 for dir, where php dotn't cack owner of these /tmp/php.... files

Second way:
make a function
copy_upload_file(full path) or open_upload_directory()
which open uploades file (/tmp/php.....) and don't check owner of these file

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-26 06:03 UTC] zak@php.net
If I am reading this correctly, it is not a bug report - instead it is a couple of suggestions on how to manage file uploading in safe mode
 [2000-07-26 07:29 UTC] joey@php.net
I agree. Looks like a feature request to me.
 [2000-07-26 09:30 UTC] sniper@php.net
My personal opinion is that this feature he's asking for shouldn't be implemented. It isn't safe mode then..;-) 

There is an solution for this, change php.ini directive:

upload_tmp_dir = ./tmp/ 

Then users have their own tmp-dir where uploads are located.

--Jani
 [2000-11-21 03:58 UTC] sniper@php.net
Duplicate of #5575 (one part of it)
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC