php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48159 After a search, section drop-down changes to "online documentation"
Submitted: 2009-05-06 04:18 UTC Modified: 2009-05-06 18:45 UTC
From: php at atu dot cjb dot net Assigned:
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at atu dot cjb dot net
New email:
PHP Version: OS:

 

 [2009-05-06 04:18 UTC] php at atu dot cjb dot net
Description:
------------
Every search that is performed leaves the section drop-down as:

<option value="manual"   selected="selected">online documentation</option>

Reproduce code:
---------------
Go to:

http://ca.php.net/manual/en/function.date.php

At the top of the page fill in:

   search for __anything__ in the [function list]

Submit the search.

Expected result:
----------------
As the web site has done for all the years I've used it, perform a search for "anything" and maintain the section drop-down as "function list".

Actual result:
--------------
The section drop-down is forced to be "online documentation".

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-06 04:45 UTC] philip@php.net
Today I changed the default from 'function list' to 'online 
documentation' so this is intentional and not a bug.

The site has never retained previous selections here, as it has always 
reverted back to the default. Whether this should be handled differently 
will be discussed while the site is redesigned these upcoming months. 
Likely we'll end up with a mashup of search results as the default and  
additional options like 'search last query as function list instead?' 
...

If you feel the change of the default is a poor design decision (or 
simply would like to discuss it and find alternatives) then please 
instead use the php-webmaster@lists.php.net mailing list.
 [2009-05-06 18:45 UTC] philip@php.net
This change has been reverted in favour of researching the following:

 http://wiki.php.net/ideas/phpnetsearch
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 18 07:06:35 2022 UTC